summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-06-19 11:23:07 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:15:41 +0200
commitfebd96e7c29cdeb08a0cdf9148b1c5bae6062cdb (patch)
tree43fbe400229b195118d1ad492beb2b990b2a934f /gnu
parentf913f575ea186238fe72fb7bd090a309fba31fa5 (diff)
downloadguix-febd96e7c29cdeb08a0cdf9148b1c5bae6062cdb.tar.gz
gnu: Add texlive-mpattern.
* gnu/packages/tex.scm (texlive-mpattern): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 7e83bb805e..707738e778 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -5683,6 +5683,25 @@ polyhedra) in MetaPost.")
 heads to be used with MetaPost commands")
     (license license:public-domain)))
 
+(define-public texlive-mpattern
+  (package
+    (name "texlive-mpattern")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/metapost/mpattern/"
+                   "metapost/mpattern/")
+             (base32
+              "00g250vl6gnvwx6zgmfqcw3nwkh546i1vjz4zjp3dc5n5yj5y6ls")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/mpattern")
+    (synopsis "Patterns in MetaPost")
+    (description
+     "This package provides a package for defining and using patterns in MetaPost,
+using the Pattern Color Space available in PostScript Level 2.")
+    (license license:public-domain)))
+
 (define-public texlive-natbib
   (package
     (name "texlive-natbib")