summary refs log tree commit diff
path: root/guix-download.in
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2013-01-30 16:30:49 +0100
committerLudovic Courtès <ludo@gnu.org>2013-01-30 16:30:49 +0100
commita9ebd9efd0d97159acbec848ad5fe06f022c8235 (patch)
tree718f8a04ac525537ed2e297bf38bbedb68f4e8f1 /guix-download.in
parentfd060fd30da53f2b0856f6f451f8fd7b8c760d70 (diff)
downloadguix-a9ebd9efd0d97159acbec848ad5fe06f022c8235.tar.gz
store: Remove the `fixed?' parameter from `add-to-store'.
* guix/store.scm (add-to-store): Remove the `fixed?' parameter from the
  public interface.
* gnu/packages/bootstrap.scm, guix-download.in, guix/derivations.scm,
  guix/packages.scm, tests/derivations.scm: Update all callers
  accordingly.
Diffstat (limited to 'guix-download.in')
-rw-r--r--guix-download.in4
1 files changed, 2 insertions, 2 deletions
diff --git a/guix-download.in b/guix-download.in
index 4b814699ca..ea62b09a7b 100644
--- a/guix-download.in
+++ b/guix-download.in
@@ -68,7 +68,7 @@ store path."
               (fetch temp))))
        (close port)
        (and result
-            (add-to-store store name #t #f "sha256" temp))))))
+            (add-to-store store name #f "sha256" temp))))))
 
 ;;;
 ;;; Command-line options.
@@ -148,7 +148,7 @@ and the hash of its contents.\n"))
          (path  (case (uri-scheme uri)
                   ((file)
                    (add-to-store store (basename (uri-path uri))
-                                 #t #f "sha256" (uri-path uri)))
+                                 #f "sha256" (uri-path uri)))
                   (else
                    (fetch-and-store store
                                     (cut url-fetch arg <>