summary refs log tree commit diff
path: root/nix/libstore/globals.cc
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-05-06 23:22:04 +0200
committerLudovic Courtès <ludo@gnu.org>2015-05-06 23:22:04 +0200
commitc69944c511b89d3fdbffe00353e27d1e1c5f670c (patch)
treef260f7f5c856615ffedbc5a610cf834aba3b5b91 /nix/libstore/globals.cc
parenta1dd396cc02922372314c35c8035a38bfeea08df (diff)
parent8e9140cfdef9dbd1eb61e4c75c91d452ab5e4a74 (diff)
downloadguix-c69944c511b89d3fdbffe00353e27d1e1c5f670c.tar.gz
Merge commit '8e9140cfdef9dbd1eb61e4c75c91d452ab5e4a74' into nix
Conflicts:
	Makefile.config.in
	configure.ac
	dev-shell
	doc/manual/builtins.xml
	doc/manual/conf-file.xml
	doc/manual/local.mk
	doc/manual/nix-instantiate.xml
	doc/manual/nix-store.xml
	doc/manual/writing-nix-expressions.xml
	misc/emacs/nix-mode.el
	perl/lib/Nix/CopyClosure.pm
	release.nix
	scripts/nix-build.in
	scripts/nix-copy-closure.in
	src/download-via-ssh/download-via-ssh.cc
	src/libexpr/common-opts.cc
	src/libexpr/common-opts.hh
	src/libexpr/eval.cc
	src/libexpr/eval.hh
	src/libexpr/local.mk
	src/libexpr/nixexpr.cc
	src/libexpr/nixexpr.hh
	src/libexpr/parser.y
	src/libexpr/primops.cc
	src/libexpr/symbol-table.hh
	src/libmain/shared.cc
	src/libstore/local.mk
	src/nix-env/nix-env.cc
	src/nix-instantiate/nix-instantiate.cc
	src/nix-store/local.mk
	src/nix-store/nix-store.cc
	src/nix-store/serve-protocol.hh
	tests/lang.sh
	tests/lang/eval-okay-context.nix
	tests/lang/eval-okay-search-path.exp
	tests/lang/eval-okay-search-path.nix
	tests/local.mk
	tests/nix-copy-closure.nix
Diffstat (limited to 'nix/libstore/globals.cc')
-rw-r--r--nix/libstore/globals.cc3
1 files changed, 3 insertions, 0 deletions
diff --git a/nix/libstore/globals.cc b/nix/libstore/globals.cc
index 86fa56739c..62c2fd6290 100644
--- a/nix/libstore/globals.cc
+++ b/nix/libstore/globals.cc
@@ -55,6 +55,7 @@ Settings::Settings()
     envKeepDerivations = false;
     lockCPU = getEnv("NIX_AFFINITY_HACK", "1") == "1";
     showTrace = false;
+    enableImportNative = false;
 }
 
 
@@ -141,6 +142,8 @@ void Settings::update()
     get(envKeepDerivations, "env-keep-derivations");
     get(sshSubstituterHosts, "ssh-substituter-hosts");
     get(useSshSubstituter, "use-ssh-substituter");
+    get(logServers, "log-servers");
+    get(enableImportNative, "allow-unsafe-native-code-during-evaluation");
 
     string subs = getEnv("NIX_SUBSTITUTERS", "default");
     if (subs == "default") {