summary refs log tree commit diff
path: root/nix/libstore
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2019-02-03 22:30:18 +0100
committerLudovic Courtès <ludo@gnu.org>2019-02-04 00:03:30 +0100
commit65d13e3043d90382f79b1780e06dc671ae451edf (patch)
treece76bd24b818f161366238fef0e4ae1c6e1cb119 /nix/libstore
parent765a5bf1677ad6bc77ed65df4f63da9ef77bb55a (diff)
downloadguix-65d13e3043d90382f79b1780e06dc671ae451edf.tar.gz
daemon: Remove unused 'NIX_DATA_DIR' environment variable.
* nix/libstore/globals.hh (Settings)[nixDataDir]: Remove.
* nix/libstore/globals.cc (Settings:processEnvironment): Remove setting
of 'nixDataDir'.
* nix/local.mk (libstore_a_CPPFLAGS): Remove '-DNIX_DATA_DIR'.
Diffstat (limited to 'nix/libstore')
-rw-r--r--nix/libstore/globals.cc1
-rw-r--r--nix/libstore/globals.hh2
2 files changed, 0 insertions, 3 deletions
diff --git a/nix/libstore/globals.cc b/nix/libstore/globals.cc
index ac92971887..130b0937fd 100644
--- a/nix/libstore/globals.cc
+++ b/nix/libstore/globals.cc
@@ -66,7 +66,6 @@ Settings::Settings()
 void Settings::processEnvironment()
 {
     nixStore = canonPath(getEnv("NIX_STORE_DIR", getEnv("NIX_STORE", NIX_STORE_DIR)));
-    nixDataDir = canonPath(getEnv("NIX_DATA_DIR", NIX_DATA_DIR));
     nixLogDir = canonPath(getEnv("GUIX_LOG_DIRECTORY", NIX_LOG_DIR));
     nixStateDir = canonPath(getEnv("GUIX_STATE_DIRECTORY", NIX_STATE_DIR));
     nixDBPath = getEnv("GUIX_DATABASE_DIRECTORY", nixStateDir + "/db");
diff --git a/nix/libstore/globals.hh b/nix/libstore/globals.hh
index a6935c3337..b073f724b6 100644
--- a/nix/libstore/globals.hh
+++ b/nix/libstore/globals.hh
@@ -45,8 +45,6 @@ struct Settings {
     /* The directory where we store sources and derived files. */
     Path nixStore;
 
-    Path nixDataDir; /* !!! fix */
-
     /* The directory where we log various operations. */
     Path nixLogDir;