summary refs log tree commit diff
path: root/nix/libstore
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2018-06-08 11:03:31 +0200
committerLudovic Courtès <ludo@gnu.org>2018-06-14 11:17:00 +0200
commitea0a06cee2ba05451f94714a4f913db02efbe92c (patch)
tree8447b4531818371310470446a17f77d313bb991a /nix/libstore
parentdf2f6400b1fbc282ef4d6dd7124ea1c17adc23c2 (diff)
downloadguix-ea0a06cee2ba05451f94714a4f913db02efbe92c.tar.gz
Remove 'guix-register' and its traces.
* Makefile.am (SH_TESTS): Remove tests/guix-register.sh.
* build-aux/pre-inst-env.in (GUIX_REGISTER): Remove.
* gnu/build/install.scm (directives): Remove outdated comment.
* gnu/build/vm.scm (root-partition-initializer): Update comment.
* gnu/packages/package-management.scm (guix-register): Remove.
* guix/config.scm.in (%sbindir, %guix-register-program): Remove.
* guix/scripts/system.scm (install): Adjust docstring.
* guix/self.scm (make-config.scm): Remove #:guix.  Do not generate
%sbindir and %guix-register-program.
(specification->package): Remove "guix".
* nix/guix-register/guix-register.cc: Remove.
* nix/libstore/store-api.cc (decodeValidPathInfo): Remove.
* nix/libstore/store-api.hh (decodeValidPathInfo): Remove declaration.
* nix/local.mk (sbin_PROGRAMS, guix_register_SOURCES)
(guix_register_CPPFLAGS, guix_register_LDFLAGS): Remove.
* tests/guix-register.sh: Remove.
Diffstat (limited to 'nix/libstore')
-rw-r--r--nix/libstore/store-api.cc26
-rw-r--r--nix/libstore/store-api.hh4
2 files changed, 0 insertions, 30 deletions
diff --git a/nix/libstore/store-api.cc b/nix/libstore/store-api.cc
index 6742d2ed49..9e07c67e97 100644
--- a/nix/libstore/store-api.cc
+++ b/nix/libstore/store-api.cc
@@ -226,32 +226,6 @@ string StoreAPI::makeValidityRegistration(const PathSet & paths,
     return s;
 }
 
-
-ValidPathInfo decodeValidPathInfo(std::istream & str, bool hashGiven)
-{
-    ValidPathInfo info;
-    getline(str, info.path);
-    if (str.eof()) { info.path = ""; return info; }
-    if (hashGiven) {
-        string s;
-        getline(str, s);
-        info.hash = parseHash(htSHA256, s);
-        getline(str, s);
-        if (!string2Int(s, info.narSize)) throw Error("number expected");
-    }
-    getline(str, info.deriver);
-    string s; int n;
-    getline(str, s);
-    if (!string2Int(s, n)) throw Error("number expected");
-    while (n--) {
-        getline(str, s);
-        info.references.insert(s);
-    }
-    if (!str || str.eof()) throw Error("missing input");
-    return info;
-}
-
-
 string showPaths(const PathSet & paths)
 {
     string s;
diff --git a/nix/libstore/store-api.hh b/nix/libstore/store-api.hh
index e957cedebc..2d9dcbd573 100644
--- a/nix/libstore/store-api.hh
+++ b/nix/libstore/store-api.hh
@@ -371,10 +371,6 @@ std::shared_ptr<StoreAPI> openStore(bool reserveSpace = true);
 string showPaths(const PathSet & paths);
 
 
-ValidPathInfo decodeValidPathInfo(std::istream & str,
-    bool hashGiven = false);
-
-
 /* Export multiple paths in the format expected by ‘nix-store
    --import’. */
 void exportPaths(StoreAPI & store, const Paths & paths,