summary refs log tree commit diff
path: root/nix/libutil/gcrypt-hash.hh
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2020-06-23 12:11:00 +0200
committerLudovic Courtès <ludo@gnu.org>2020-06-27 23:42:20 +0200
commit8dc6c387852bb9505be44567a5f56913633cc23a (patch)
tree872914ede2ea33f72f8c09b2c3517fdf92ee85f5 /nix/libutil/gcrypt-hash.hh
parent3fb6b8f30444d41963ba5bdd441123a6d2df17bd (diff)
downloadguix-8dc6c387852bb9505be44567a5f56913633cc23a.tar.gz
daemon: Remove OpenSSL hash compatibility wrappers.
* nix/libutil/hash.cc (struct Ctx): Copy from gcrypt-hash.hh.
(start, update, finish): Use gcrypt functions directly instead of
OpenSSL-like wrappers.
* nix/libutil/gcrypt-hash.cc, nix/libutil/gcrypt-hash.hh,
nix/libutil/md5.h, nix/libutil/sha1.h, nix/libutil/sha256.h,
nix/libutil/sha512.h: Remove.
* nix/local.mk (libutil_a_SOURCES, libutil_headers): Adjust
accordingly.
Diffstat (limited to 'nix/libutil/gcrypt-hash.hh')
-rw-r--r--nix/libutil/gcrypt-hash.hh50
1 files changed, 0 insertions, 50 deletions
diff --git a/nix/libutil/gcrypt-hash.hh b/nix/libutil/gcrypt-hash.hh
deleted file mode 100644
index 11f061159f..0000000000
--- a/nix/libutil/gcrypt-hash.hh
+++ /dev/null
@@ -1,50 +0,0 @@
-/* GNU Guix --- Functional package management for GNU
-   Copyright (C) 2012, 2013  Ludovic Courtès <ludo@gnu.org>
-
-   This file is part of GNU Guix.
-
-   GNU Guix is free software; you can redistribute it and/or modify it
-   under the terms of the GNU General Public License as published by
-   the Free Software Foundation; either version 3 of the License, or (at
-   your option) any later version.
-
-   GNU Guix is distributed in the hope that it will be useful, but
-   WITHOUT ANY WARRANTY; without even the implied warranty of
-   MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
-   GNU General Public License for more details.
-
-   You should have received a copy of the GNU General Public License
-   along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.  */
-
-/* An OpenSSL-like interface to GNU libgcrypt cryptographic hash
-   functions.  */
-
-#pragma once
-#include <gcrypt.h>
-#include <unistd.h>
-
-struct guix_hash_context
-{
-  /* This copy constructor is needed in 'HashSink::currentHash()' where we
-     expect the copy of a 'Ctx' object to yield a truly different context.  */
-  guix_hash_context (guix_hash_context &ref)
-  {
-    if (ref.md_handle == NULL)
-      md_handle = NULL;
-    else
-      gcry_md_copy (&md_handle, ref.md_handle);
-  }
-
-  /* Make sure 'md_handle' is always initialized.  */
-  guix_hash_context (): md_handle (NULL) { };
-
-  gcry_md_hd_t md_handle;
-};
-
-extern "C" {
-extern void guix_hash_init (struct guix_hash_context *ctx, int algo);
-extern void guix_hash_update (struct guix_hash_context *ctx, const void *buffer,
-			      size_t len);
-extern void guix_hash_final (void *resbuf, struct guix_hash_context *ctx,
-			     int algo);
-}