summary refs log tree commit diff
path: root/nix/local.mk
diff options
context:
space:
mode:
authorEelco Dolstra <eelco.dolstra@logicblox.com>2016-03-30 13:27:25 +0200
committerLudovic Courtès <ludo@gnu.org>2016-10-28 22:30:17 +0200
commit7bed5d91dea6ecff565d51a021e6f99718d04f86 (patch)
tree3b6e5266ce3359c4125faa9f77ab786a9891595a /nix/local.mk
parent517ce0c15bdf802b3c378fff48b1e5be4167a4fa (diff)
downloadguix-7bed5d91dea6ecff565d51a021e6f99718d04f86.tar.gz
daemon: Factor out SQLite handling.
* nix/libstore/local-store.cc: Move SQLite code to...
* nix/libstore/sqlite.cc, nix/libstore/sqlite.hh: ... here.  New files.
* nix/local.mk (libstore_a_SOURCES): Add sqlite.cc.
(libstore_headers): Add sqlite.hh.

Co-authored-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'nix/local.mk')
-rw-r--r--nix/local.mk4
1 files changed, 3 insertions, 1 deletions
diff --git a/nix/local.mk b/nix/local.mk
index b0e9bc1a2b..c666edd033 100644
--- a/nix/local.mk
+++ b/nix/local.mk
@@ -86,7 +86,8 @@ libstore_a_SOURCES =				\
   %D%/libstore/local-store.cc			\
   %D%/libstore/build.cc				\
   %D%/libstore/pathlocks.cc			\
-  %D%/libstore/derivations.cc
+  %D%/libstore/derivations.cc			\
+  %D%/libstore/sqlite.cc
 
 libstore_headers =				\
   %D%/libstore/references.hh			\
@@ -96,6 +97,7 @@ libstore_headers =				\
   %D%/libstore/derivations.hh			\
   %D%/libstore/misc.hh				\
   %D%/libstore/local-store.hh			\
+  %D%/libstore/sqlite.hh			\
   %D%/libstore/store-api.hh
 
 libstore_a_CPPFLAGS =				\