summary refs log tree commit diff
path: root/nix/nix-daemon
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2019-02-04 16:14:09 +0100
committerLudovic Courtès <ludo@gnu.org>2019-02-04 16:20:01 +0100
commit959eaa1eb834fd47ceab3c5bbbe4967e808d530b (patch)
tree11af589b50530f3cdd09c895077a203e332464b9 /nix/nix-daemon
parent4d4a38f620520acc787ff5db2be3736923e14235 (diff)
downloadguix-959eaa1eb834fd47ceab3c5bbbe4967e808d530b.tar.gz
daemon: Add "/guix" to default 'nixLibexecDir'.
This makes it easier to run the uninstalled daemon.

* nix/local.mk (libstore_a_CPPFLAGS): Append "/guix" to
NIX_LIBEXEC_DIR.
* build-aux/pre-inst-env.in (NIX_LIBEXEC_DIR): Adjust comment.
* nix/libstore/builtins.cc (builtinDownload): Remove SUBDIR and its
use.
* nix/libstore/local-store.cc (runAuthenticationProgram): Ditto.
* nix/libstore/gc.cc (addAdditionalRoots): Remove "/guix" prefix.
* nix/nix-daemon/guix-daemon.cc (main): Ditto.
Diffstat (limited to 'nix/nix-daemon')
-rw-r--r--nix/nix-daemon/guix-daemon.cc14
1 files changed, 3 insertions, 11 deletions
diff --git a/nix/nix-daemon/guix-daemon.cc b/nix/nix-daemon/guix-daemon.cc
index 23ef46ef8c..f47d142612 100644
--- a/nix/nix-daemon/guix-daemon.cc
+++ b/nix/nix-daemon/guix-daemon.cc
@@ -480,7 +480,7 @@ main (int argc, char *argv[])
 	{
 	  std::string build_hook;
 
-	  build_hook = settings.nixLibexecDir + "/guix/offload";
+	  build_hook = settings.nixLibexecDir + "/offload";
 	  setenv ("NIX_BUILD_HOOK", build_hook.c_str (), 1);
 	}
 #else
@@ -498,16 +498,8 @@ main (int argc, char *argv[])
 	       format ("build log compression: %1%") % settings.logCompression);
 
       if (settings.useSubstitutes)
-	{
-	  /* XXX: Hack our way to use the 'substitute' script from
-	     'LIBEXECDIR/guix' or just 'LIBEXECDIR', depending on whether
-	     we're running uninstalled or not.  */
-	  const string subdir = getenv("GUIX_UNINSTALLED") != NULL
-	    ? "" : "/guix";
-
-	  settings.substituters.push_back (settings.nixLibexecDir
-					   + subdir + "/substitute");
-	}
+	settings.substituters.push_back (settings.nixLibexecDir
+					 + "/substitute");
       else
 	/* Clear the substituter list to make sure nothing ever gets
 	   substituted, regardless of the client's settings.  */