summary refs log tree commit diff
path: root/nix
diff options
context:
space:
mode:
authorDavid Craven <david@craven.ch>2016-06-23 19:44:38 +0200
committerLudovic Courtès <ludo@gnu.org>2016-06-26 23:11:07 +0200
commit9dd674db017dbdc451cfd35da2dc3ce08db0726a (patch)
treefdab5b2f68ea609b90c80606466ad7702f3f8dbc /nix
parent8ac6282c4b97ece43b922a8c1a99a0a8e753c765 (diff)
downloadguix-9dd674db017dbdc451cfd35da2dc3ce08db0726a.tar.gz
daemon: Rename 'NIX_CONF_DIR' to 'GUIX_CONFIGURATION_DIRECTORY'.
Partly fixes <http://bugs.gnu.org/22459>.
Reported by Jeff Mickey <j@codemac.net> and David Craven <david@craven.ch>.

* nix/libstore/globals.cc (Settings::processEnvironment()): Change
'NIX_CONF_DIR' to 'GUIX_CONFIGURATION_DIRECTORY'.
* nix/local.mk (libstore_a_CPPFLAGS): Likewise.
* guix/config.scm.in (%config-directory): Likewise.
* build-aux/test-env.in: Likewise.
* gnu/packages/patches/hydra-automake-1.15.patch: Likewise.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'nix')
-rw-r--r--nix/libstore/globals.cc2
-rw-r--r--nix/local.mk2
2 files changed, 2 insertions, 2 deletions
diff --git a/nix/libstore/globals.cc b/nix/libstore/globals.cc
index 84fc885eba..65dad24d91 100644
--- a/nix/libstore/globals.cc
+++ b/nix/libstore/globals.cc
@@ -67,7 +67,7 @@ void Settings::processEnvironment()
     nixLogDir = canonPath(getEnv("NIX_LOG_DIR", NIX_LOG_DIR));
     nixStateDir = canonPath(getEnv("NIX_STATE_DIR", NIX_STATE_DIR));
     nixDBPath = getEnv("NIX_DB_DIR", nixStateDir + "/db");
-    nixConfDir = canonPath(getEnv("NIX_CONF_DIR", NIX_CONF_DIR));
+    nixConfDir = canonPath(getEnv("GUIX_CONFIGURATION_DIRECTORY", GUIX_CONFIGURATION_DIRECTORY));
     nixLibexecDir = canonPath(getEnv("NIX_LIBEXEC_DIR", NIX_LIBEXEC_DIR));
     nixBinDir = canonPath(getEnv("NIX_BIN_DIR", NIX_BIN_DIR));
     nixDaemonSocketFile = canonPath(nixStateDir + DEFAULT_SOCKET_PATH);
diff --git a/nix/local.mk b/nix/local.mk
index 07a92f74ea..b0e9bc1a2b 100644
--- a/nix/local.mk
+++ b/nix/local.mk
@@ -106,7 +106,7 @@ libstore_a_CPPFLAGS =				\
   -DNIX_DATA_DIR=\"$(datadir)\"			\
   -DNIX_STATE_DIR=\"$(localstatedir)/guix\"	\
   -DNIX_LOG_DIR=\"$(localstatedir)/log/guix\"	\
-  -DNIX_CONF_DIR=\"$(sysconfdir)/guix\"		\
+  -DGUIX_CONFIGURATION_DIRECTORY=\"$(sysconfdir)/guix\"		\
   -DNIX_LIBEXEC_DIR=\"$(libexecdir)\"		\
   -DNIX_BIN_DIR=\"$(bindir)\"			\
   -DOPENSSL_PATH="\"guix-authenticate\""	\