summary refs log tree commit diff
path: root/release.nix
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2012-12-13 00:28:51 +0100
committerLudovic Courtès <ludo@gnu.org>2012-12-13 00:28:51 +0100
commit5fb868033fd8620eb6339df33fac00df21027790 (patch)
treea227086b7f6c678e79dd7889b84970ace89927d5 /release.nix
parentc9b70836d080150046633edc782fdaaff9fc6d9c (diff)
downloadguix-5fb868033fd8620eb6339df33fac00df21027790.tar.gz
release.nix: Build the daemon.
* release.nix (tarball): Add `preAutoconf'.  Augment `buildInputs' and
  `configureFlags' to allow daemon builds.
  (build): Likewise.
Diffstat (limited to 'release.nix')
-rw-r--r--release.nix13
1 files changed, 7 insertions, 6 deletions
diff --git a/release.nix b/release.nix
index 1b913b497b..fecbfb69d7 100644
--- a/release.nix
+++ b/release.nix
@@ -48,11 +48,12 @@ let
       pkgs.releaseTools.sourceTarball {
         name = "guix-tarball";
         src = <guix>;
-        buildInputs = with pkgs; [ guile ];
+        buildInputs = with pkgs; [ guile sqlite bzip2 git libgcrypt ];
         buildNativeInputs = with pkgs; [ texinfo gettext cvs pkgconfig ];
+        preAutoconf = ''git config submodule.gnulib.url "${<gnulib>}"'';
         configureFlags =
-          [ "--with-nix-prefix=${pkgs.nix}"
-            "--with-libgcrypt-prefix=${pkgs.libgcrypt}"
+          [ "--with-libgcrypt-prefix=${pkgs.libgcrypt}"
+            "--localstatedir=/nix/var/nix"
           ];
       };
 
@@ -62,12 +63,12 @@ let
       let pkgs = import nixpkgs { inherit system; }; in
       pkgs.releaseTools.nixBuild {
         name = "guix";
-        buildInputs = [ pkgs.guile ];
+        buildInputs = with pkgs; [ guile sqlite bzip2 libgcrypt ];
         buildNativeInputs = [ pkgs.pkgconfig ];
         src = jobs.tarball;
         configureFlags =
-          [ "--with-nix-prefix=${pkgs.nix}"
-            "--with-libgcrypt-prefix=${pkgs.libgcrypt}"
+          [ "--with-libgcrypt-prefix=${pkgs.libgcrypt}"
+            "--localstatedir=/nix/var/nix"
           ];
 
         preBuild =