summary refs log tree commit diff
path: root/srfi/srfi-64.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2018-07-17 15:36:00 +0200
committerLudovic Courtès <ludo@gnu.org>2018-07-18 00:22:33 +0200
commit02d7e9417d6b09994fbdf5eda96f0ff82b1c5dad (patch)
treec162208902a85199bc35b6fe4e946a547a2a2ea8 /srfi/srfi-64.scm
parent36a71ce04d357a594f4b9c17712e9a2330a6fbab (diff)
downloadguix-02d7e9417d6b09994fbdf5eda96f0ff82b1c5dad.tar.gz
build: Remove copy of (srfi srfi-64).
SRFI-64 was added in Guile 2.0.10 and we require 2.0.13 or newer.

* Makefile.am (EXTRA_DIST): Remove srfi/*.
* srfi: Remove directory.
Diffstat (limited to 'srfi/srfi-64.scm')
-rw-r--r--srfi/srfi-64.scm41
1 files changed, 0 insertions, 41 deletions
diff --git a/srfi/srfi-64.scm b/srfi/srfi-64.scm
deleted file mode 100644
index f053443b39..0000000000
--- a/srfi/srfi-64.scm
+++ /dev/null
@@ -1,41 +0,0 @@
-(define-module (srfi srfi-64)
-  #:export (test-begin ;; must be listed first, since in Kawa (at least) it is "magic".
-            test-end test-assert test-eqv test-eq test-equal
-            test-approximate test-assert test-error test-apply test-with-runner
-            test-match-nth test-match-all test-match-any test-match-name
-            test-skip test-expect-fail test-read-eval-string
-            test-runner-group-path test-group test-group-with-cleanup
-            test-result-ref test-result-set! test-result-clear test-result-remove
-            test-result-kind test-passed?
-            test-log-to-file
-                                                  ; Misc test-runner functions
-            test-runner? test-runner-reset test-runner-null
-            test-runner-simple test-runner-current test-runner-factory test-runner-get
-            test-runner-create test-runner-test-name
-            ;; test-runner field setter and getter functions - see %test-record-define:
-            test-runner-pass-count test-runner-pass-count!
-            test-runner-fail-count test-runner-fail-count!
-            test-runner-xpass-count test-runner-xpass-count!
-            test-runner-xfail-count test-runner-xfail-count!
-            test-runner-skip-count test-runner-skip-count!
-            test-runner-group-stack test-runner-group-stack!
-            test-runner-on-test-begin test-runner-on-test-begin!
-            test-runner-on-test-end test-runner-on-test-end!
-            test-runner-on-group-begin test-runner-on-group-begin!
-            test-runner-on-group-end test-runner-on-group-end!
-            test-runner-on-final test-runner-on-final!
-            test-runner-on-bad-count test-runner-on-bad-count!
-            test-runner-on-bad-end-name test-runner-on-bad-end-name!
-            test-result-alist test-result-alist!
-            test-runner-aux-value test-runner-aux-value!
-            ;; default/simple call-back functions, used in default test-runner,
-            ;; but can be called to construct more complex ones.
-            test-on-group-begin-simple test-on-group-end-simple
-            test-on-bad-count-simple test-on-bad-end-name-simple
-            test-on-final-simple test-on-test-end-simple
-            test-on-final-simple))
-
-(cond-expand-provide (current-module) '(srfi-64))
-
-;; Load Per Bothner's original SRFI-64 implementation.
-(load-from-path "srfi/srfi-64.upstream.scm")