summary refs log tree commit diff
path: root/test-env.in
diff options
context:
space:
mode:
authorNikita Karetnikov <nikita@karetnikov.org>2014-03-29 00:06:41 +0100
committerLudovic Courtès <ludo@gnu.org>2014-03-30 12:02:10 +0200
commite9c6c58418043f36862a798389f3a7f4253f74cc (patch)
treec356b60c18a2aa02284dc565f6671f95f86fe8fb /test-env.in
parent24194b6b543427510766813fdce01cfb79d00651 (diff)
downloadguix-e9c6c58418043f36862a798389f3a7f4253f74cc.tar.gz
substitute-binary: Support the Signature field of a narinfo file.
* guix/scripts/substitute-binary.scm (<narinfo>): Add the 'signature'
  and 'contents' fields.
  (narinfo-signature->canonical-sexp): New function.
  (narinfo-maker): Add the 'signature' argument and use it.
  (assert-valid-signature): New function.
  (read-narinfo): Support the Signature field.
  (write-narinfo): Use 'narinfo-contents'.
  (%allow-unauthenticated-substitutes?): New variable.
* guix/base64.scm, tests/base64.scm, tests/substitute-binary.scm: New files.
* Makefile.am (SCM_TESTS): Add tests/base64.scm and
  tests/substitute-binary.scm.
  (MODULES): Add guix/base64.scm.
* test-env.in: Set 'GUIX_ALLOW_UNAUTHENTICATED_SUBSTITUTES'.
Diffstat (limited to 'test-env.in')
-rw-r--r--test-env.in5
1 files changed, 5 insertions, 0 deletions
diff --git a/test-env.in b/test-env.in
index 3853ce91ef..a3b3536145 100644
--- a/test-env.in
+++ b/test-env.in
@@ -58,12 +58,17 @@ then
     rm -rf "$NIX_STATE_DIR/substituter-data"
     mkdir -p "$NIX_STATE_DIR/substituter-data"
 
+    # For a number of tests, we want to allow unsigned narinfos, for
+    # simplicity.
+    GUIX_ALLOW_UNAUTHENTICATED_SUBSTITUTES=yes
+
     # Place for the substituter's cache.
     XDG_CACHE_HOME="$NIX_STATE_DIR/cache-$$"
 
     export NIX_IGNORE_SYMLINK_STORE NIX_STORE_DIR			\
 	NIX_LOCALSTATE_DIR NIX_LOG_DIR NIX_STATE_DIR NIX_DB_DIR		\
 	NIX_ROOT_FINDER NIX_SETUID_HELPER GUIX_BINARY_SUBSTITUTE_URL	\
+        GUIX_ALLOW_UNAUTHENTICATED_SUBSTITUTES				\
         NIX_CONF_DIR XDG_CACHE_HOME
 
     # Do that because store.scm calls `canonicalize-path' on it.