summary refs log tree commit diff
path: root/tests/builders.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2012-11-04 22:04:41 +0100
committerLudovic Courtès <ludo@gnu.org>2012-11-04 22:04:41 +0100
commit18633d4f350160c2eb6f5101a628010322336e91 (patch)
treeb4ecda9841422044bb583026e129624dd47f3c8f /tests/builders.scm
parent9d9e64508186e5f9efbe45302134cd709b25e47b (diff)
downloadguix-18633d4f350160c2eb6f5101a628010322336e91.tar.gz
distro: Move bootstrap packages to (distro packages bootstrap).
* distro/packages/base.scm (glibc-dynamic-linker, %bootstrap-guile,
  bootstrap-origin, package-from-tarball, %bootstrap-base-url,
  %bootstrap-coreutils&co, %bootstrap-binutils, %bootstrap-glibc,
  %bootstrap-gcc, %bootstrap-inputs, package-with-bootstrap-guile): Move
  to ...
* distro/packages/bootstrap.scm: ... here.  New file.
* Makefile.am (MODULES): Add it.
* tests/builders.scm: Use (distro packages bootstrap).
  (%bootstrap-guile): Remove.
* tests/packages.scm: Likewise.
* tests/union.scm: Likewise, and remove @@ to access %bootstrap-inputs.
* tests/derivations.scm: Use (distro packages bootstrap) and remove @@
  to access %bootstrap-coreutils&co.
* HACKING (When the platform is supported by Nixpkgs): Update
  accordingly.
Diffstat (limited to 'tests/builders.scm')
-rw-r--r--tests/builders.scm4
1 files changed, 1 insertions, 3 deletions
diff --git a/tests/builders.scm b/tests/builders.scm
index d79603f7da..8b0fa117a9 100644
--- a/tests/builders.scm
+++ b/tests/builders.scm
@@ -25,6 +25,7 @@
   #:use-module (guix utils)
   #:use-module (guix derivations)
   #:use-module ((guix packages) #:select (package-derivation))
+  #:use-module (distro packages bootstrap)
   #:use-module (ice-9 match)
   #:use-module (srfi srfi-1)
   #:use-module (srfi srfi-64))
@@ -48,9 +49,6 @@
               (list name (package-derivation %store package))))
             (@@ (distro packages base) %boot0-inputs))))
 
-(define %bootstrap-guile
-  (@@ (distro packages base) %bootstrap-guile))
-
 
 (test-begin "builders")