summary refs log tree commit diff
path: root/tests/cpan.scm
diff options
context:
space:
mode:
authorMathieu Lirzin <mthl@gnu.org>2015-10-26 23:47:24 +0100
committerMathieu Lirzin <mthl@gnu.org>2016-03-28 15:31:41 +0200
commit75f8874fe98eeb4a0a6133840600caf27936eba3 (patch)
tree130dff2d4dc4c92bb54e0f26566d220e8bd92e3c /tests/cpan.scm
parent41fa926f307af824f539fa3e6ae36fac00579f22 (diff)
downloadguix-75f8874fe98eeb4a0a6133840600caf27936eba3.tar.gz
build: Add a Guile custom test driver using SRFI-64.
Before that '.log' files for scheme tests were fragmented and not
included in test-suite.log.  This unifies the semantics of SRFI-64 API
with Automake test suite.

* build-aux/test-driver.scm: New file.
* Makefile.am (SCM_LOG_DRIVER, AM_SCM_LOG_DRIVER_FLAGS): New variables.
(SCM_LOG_COMPILER, AM_SCM_LOG_FLAGS): Delete variables.
(AM_TESTS_ENVIRONMENT): Set GUILE_AUTO_COMPILE to 0.
* doc/guix.texi (Running the Test Suite): Describe how to display the
detailed results.  Bug reports don't require including additional '.log'
files.
* tests/base32.scm, tests/build-utils.scm, tests/builders.scm,
tests/challenge.scm, tests/cpan.scm, tests/cpio.scm, tests/cran.scm,
tests/cve.scm, tests/derivations.scm, tests/elpa.scm,
tests/file-systems.scm, tests/gem.scm, tests/gexp.scm,
tests/gnu-maintenance.scm, tests/graph.scm, tests/gremlin.scm,
tests/hackage.scm, tests/hash.scm, tests/import-utils.scm,
tests/lint.scm, tests/monads.scm, tests/nar.scm, tests/packages.scm,
tests/pk-crypto.scm, tests/pki.scm, tests/profiles.scm,
tests/publish.scm, tests/pypi.scm, tests/records.scm,
tests/scripts-build.scm, tests/scripts.scm, tests/services.scm,
tests/sets.scm, tests/size.scm, tests/snix.scm, tests/store.scm,
tests/substitute.scm, tests/syscalls.scm, tests/system.scm,
tests/ui.scm, tests/union.scm, tests/utils.scm: Don't exit at the end of
test groups.
* tests/containers.scm: Likewise.  Use 'test-skip' instead of exiting
with error code 77.
Diffstat (limited to 'tests/cpan.scm')
-rw-r--r--tests/cpan.scm3
1 files changed, 0 insertions, 3 deletions
diff --git a/tests/cpan.scm b/tests/cpan.scm
index 583684104d..5d56f0bd2b 100644
--- a/tests/cpan.scm
+++ b/tests/cpan.scm
@@ -98,6 +98,3 @@
        (pk 'fail x #f)))))
 
 (test-end "cpan")
-
-
-(exit (= (test-runner-fail-count (test-runner-current)) 0))