summary refs log tree commit diff
path: root/tests/cpan.scm
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2015-01-08 14:51:13 -0600
committerEric Bavier <bavier@member.fsf.org>2015-01-09 10:38:26 -0600
commitd45dc6da5c802024f31dba95919c06205c5e31e4 (patch)
treecea230023a562edb0fc474eb47cc92692926ad25 /tests/cpan.scm
parent694b317c2dfac5f8b284a5831e20d89cc112bd6b (diff)
downloadguix-d45dc6da5c802024f31dba95919c06205c5e31e4.tar.gz
import: Add CPAN importer.
* guix/import/cpan.scm, guix/scripts/import/cpan.scm, tests/cpan.scm:
  New files.
* Makefile.am (MODULE)[HAVE_GUILE_JSON]: Add them.
* guix/scripts/import.scm (importers): Add cpan.
* doc/guix.texi (Requirements): Mention `guix import cpan` as a user
  of guile-json.
  (Invoking guix import): Document new `guix import cpan` command.
Diffstat (limited to 'tests/cpan.scm')
-rw-r--r--tests/cpan.scm107
1 files changed, 107 insertions, 0 deletions
diff --git a/tests/cpan.scm b/tests/cpan.scm
new file mode 100644
index 0000000000..af7b36e684
--- /dev/null
+++ b/tests/cpan.scm
@@ -0,0 +1,107 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2015 Eric Bavier <bavier@member.fsf.org>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (test-cpan)
+  #:use-module (guix import cpan)
+  #:use-module (guix base32)
+  #:use-module (guix hash)
+  #:use-module (guix tests)
+  #:use-module (srfi srfi-64)
+  #:use-module (ice-9 match))
+
+(define test-json
+  "{
+  \"metadata\" : {
+    \"prereqs\" : {
+      \"configure\" : {
+        \"requires\" : {
+          \"ExtUtils::MakeMaker\" : \"0\",
+          \"Module::Build\" : \"0.28\"
+        }
+      },
+      \"runtime\" : {
+        \"requires\" : {
+          \"Getopt::Std\" : \"0\",
+          \"Test::Script\" : \"1.05\",
+        }
+      }
+    }
+    \"name\" : \"Foo-Bar\",
+    \"version\" : \"0.1\"
+  }
+  \"name\" : \"Foo-Bar-0.1\",
+  \"distribution\" : \"Foo-Bar\",
+  \"license\" : [
+    \"perl_5\"
+  ],
+  \"abstract\" : \"Fizzle Fuzz\",
+  \"download_url\" : \"http://example.com/Foo-Bar-0.1.tar.gz\",
+  \"author\" : \"GUIX\",
+  \"version\" : \"0.1\"
+}")
+
+(define test-source
+  "foobar")
+
+(test-begin "cpan")
+
+(test-assert "cpan->guix-package"
+  ;; Replace network resources with sample data.
+  (mock ((guix build download) url-fetch
+         (lambda* (url file-name #:key (mirrors '()))
+           (with-output-to-file file-name
+             (lambda ()
+               (display
+                (match url
+                  ("http://api.metacpan.org/release/Foo-Bar"
+                   test-json)
+                  ("http://example.com/Foo-Bar-0.1.tar.gz"
+                   test-source)
+                  (_ (error "Unexpected URL: " url))))))))
+    (match (cpan->guix-package "Foo::Bar")
+      (('package
+         ('name "perl-foo-bar")
+         ('version "0.1")
+         ('source ('origin
+                    ('method 'url-fetch)
+                    ('uri ('string-append "http://example.com/Foo-Bar-"
+                                          'version ".tar.gz"))
+                    ('sha256
+                     ('base32
+                      (? string? hash)))))
+         ('build-system 'perl-build-system)
+         ('native-inputs
+          ('quasiquote
+           (("perl-module-build" ('unquote 'perl-module-build)))))
+         ('inputs
+          ('quasiquote
+           (("perl-test-script" ('unquote 'perl-test-script)))))
+         ('home-page "http://search.cpan.org/dist/Foo-Bar")
+         ('synopsis "Fizzle Fuzz")
+         ('description 'fill-in-yourself!)
+         ('license 'gpl1+))
+       (string=? (bytevector->nix-base32-string
+                  (call-with-input-string test-source port-sha256))
+                 hash))
+      (x
+       (pk 'fail x #f)))))
+
+(test-end "cpan")
+
+
+(exit (= (test-runner-fail-count (test-runner-current)) 0))