summary refs log tree commit diff
path: root/tests/gem.scm
diff options
context:
space:
mode:
authorDavid Thompson <dthompson2@worcester.edu>2015-09-01 19:57:44 -0400
committerDavid Thompson <dthompson2@worcester.edu>2015-09-01 20:00:01 -0400
commita96524cc7d302ad6a8f2cd2e970a148b360f629a (patch)
tree5bc3f8b199a48229692ff8381d7a3a80c3ee571d /tests/gem.scm
parent385a44bebb4a33517165efa2f75ab376c2263db6 (diff)
downloadguix-a96524cc7d302ad6a8f2cd2e970a148b360f629a.tar.gz
import: gem: Fix minor bug and add unit test.
* guix/import/gem.scm (make-gem-sexp): Properly handle an empty list of
  licenses.  When rendering a list of licenses, cons 'list onto the front of
  the expression.
* tests/gem.scm: New file.
* Makefile.am (SCM_TESTS): Add it.
Diffstat (limited to 'tests/gem.scm')
-rw-r--r--tests/gem.scm82
1 files changed, 82 insertions, 0 deletions
diff --git a/tests/gem.scm b/tests/gem.scm
new file mode 100644
index 0000000000..9efbda31fe
--- /dev/null
+++ b/tests/gem.scm
@@ -0,0 +1,82 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2015 David Thompson <davet@gnu.org>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (test-gem)
+  #:use-module (guix import gem)
+  #:use-module (guix base32)
+  #:use-module (guix hash)
+  #:use-module (guix tests)
+  #:use-module ((guix build utils) #:select (delete-file-recursively))
+  #:use-module (srfi srfi-64)
+  #:use-module (ice-9 match))
+
+(define test-json
+  "{
+  \"name\": \"foo\",
+  \"version\": \"1.0.0\",
+  \"sha\": \"f3676eafca9987cb5fe263df1edf2538bf6dafc712b30e17be3543a9680547a8\",
+  \"info\": \"A cool gem\",
+  \"homepage_uri\": \"https://example.com\",
+  \"dependencies\": {
+    \"runtime\": [
+      { \"name\": \"bundler\" },
+      { \"name\": \"bar\" }
+    ]
+  },
+  \"licenses\": [\"MIT\", \"Apache 2.0\"]
+}")
+
+(test-begin "gem")
+
+(test-assert "gem->guix-package"
+  ;; Replace network resources with sample data.
+  (mock ((guix import utils) url-fetch
+         (lambda (url file-name)
+           (match url
+             ("https://rubygems.org/api/v1/gems/foo.json"
+              (with-output-to-file file-name
+                (lambda ()
+                  (display test-json))))
+             (_ (error "Unexpected URL: " url)))))
+    (match (gem->guix-package "foo")
+      (('package
+         ('name "ruby-foo")
+         ('version "1.0.0")
+         ('source ('origin
+                    ('method 'url-fetch)
+                    ('uri ('rubygems-uri "foo" 'version))
+                    ('sha256
+                     ('base32
+                      "1a270mlajhrmpqbhxcqjqypnvgrq4pgixpv3w9gwp1wrrapnwrzk"))))
+         ('build-system 'ruby-build-system)
+         ('propagated-inputs
+          ('quasiquote
+           (("bundler" ('unquote 'bundler))
+            ("ruby-bar" ('unquote 'ruby-bar)))))
+         ('synopsis "A cool gem")
+         ('description "A cool gem")
+         ('home-page "https://example.com")
+         ('license ('list 'expat 'asl2.0)))
+       #t)
+      (x
+       (pk 'fail x #f)))))
+
+(test-end "gem")
+
+
+(exit (= (test-runner-fail-count (test-runner-current)) 0))