summary refs log tree commit diff
path: root/tests/graph.scm
diff options
context:
space:
mode:
authorChris Marusich <cmmarusich@gmail.com>2018-04-08 16:51:42 -0700
committerChris Marusich <cmmarusich@gmail.com>2018-05-08 21:55:46 -0700
commitede121de426f9c56820852888a0b370f0ccbce49 (patch)
treecddd5c464c259d03dd97a021922950f161cfcb13 /tests/graph.scm
parentb61cb24492c150b5eebb5227f2a7c32e4d42e1d4 (diff)
downloadguix-ede121de426f9c56820852888a0b370f0ccbce49.tar.gz
guix: Separate the package name and version with "@", not "-".
* guix/packages.scm (package-full-name): By default, use "@" to separate
  the package name and package version.  Add an optional delimiter
  argument so that there is still a way to explicitly use a different
  delimiter.
* gnu/packages/commencement.scm (gcc-boot0) <unpack-gmp&co>: Adjust
  accordingly.
* tests/graph.scm: Adjust accordingly.
* tests/profiles.scm: Adjust accordingly.
* NEWS: Mention the change.

Fixes: <https://bugs.gnu.org/31088>.
Reported by Pierre Neidhardt <ambrevar@gmail.com>.
Diffstat (limited to 'tests/graph.scm')
-rw-r--r--tests/graph.scm2
1 files changed, 1 insertions, 1 deletions
diff --git a/tests/graph.scm b/tests/graph.scm
index 5faa19298a..b86ae4a32f 100644
--- a/tests/graph.scm
+++ b/tests/graph.scm
@@ -134,7 +134,7 @@ edges."
                      (map (lambda (destination)
                             (list "p-0.drv"
                                   (string-append
-                                   (package-full-name destination)
+                                   (package-full-name destination "-")
                                    ".drv")))
                           implicit)))))))