summary refs log tree commit diff
path: root/tests/guix-build.sh
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2013-01-18 01:06:24 +0100
committerLudovic Courtès <ludo@gnu.org>2013-01-18 01:07:31 +0100
commit1ffa7090b99dfd2f54fa883929c5e78d7852657a (patch)
tree1c8bd191e31212e172b3e9158408cccd571a5020 /tests/guix-build.sh
parent08ba7ff318720d926215de83daed0da628908ca3 (diff)
downloadguix-1ffa7090b99dfd2f54fa883929c5e78d7852657a.tar.gz
distro: Change the module name space to (gnu ...).
* distro: Rename to...
* gnu: ... this.  Update module names accordingly.
* Makefile.am: Adjust accordingly.
* po/POTFILES.in: Likewise.
* distro.scm: Search for files under /gnu/packages instead of
  /distro/packages.
* gnu/packages/base.scm (ld-wrapper-boot3): Likewise.
Diffstat (limited to 'tests/guix-build.sh')
-rw-r--r--tests/guix-build.sh8
1 files changed, 4 insertions, 4 deletions
diff --git a/tests/guix-build.sh b/tests/guix-build.sh
index f03afbd494..fccf2168b1 100644
--- a/tests/guix-build.sh
+++ b/tests/guix-build.sh
@@ -27,11 +27,11 @@ if guix-build -e +;
 then false; else true; fi
 
 # Should fail because this is a source-less package.
-if guix-build -e '(@ (distro packages bootstrap) %bootstrap-glibc)' -S
+if guix-build -e '(@ (gnu packages bootstrap) %bootstrap-glibc)' -S
 then false; else true; fi
 
 # Should pass.
-guix-build -e '(@@ (distro packages base) %bootstrap-guile)' |	\
+guix-build -e '(@@ (gnu packages base) %bootstrap-guile)' |	\
     grep -e '-guile-'
 guix-build hello -d |				\
     grep -e '-hello-[0-9\.]\+\.drv$'
@@ -42,11 +42,11 @@ if guix-build hello-0.0.1 -n; then false; else true; fi
 # Keep a symlink to the result, registered as a root.
 result="t-result-$$"
 guix-build -r "$result"					\
-    -e '(@@ (distro packages base) %bootstrap-guile)'
+    -e '(@@ (gnu packages base) %bootstrap-guile)'
 test -x "$result/bin/guile"
 
 # Should fail, because $result already exists.
-if guix-build -r "$result" -e '(@@ (distro packages base) %bootstrap-guile)'
+if guix-build -r "$result" -e '(@@ (gnu packages base) %bootstrap-guile)'
 then false; else true; fi
 
 rm -f "$result"