summary refs log tree commit diff
path: root/tests/packages.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2012-11-04 22:04:41 +0100
committerLudovic Courtès <ludo@gnu.org>2012-11-04 22:04:41 +0100
commit18633d4f350160c2eb6f5101a628010322336e91 (patch)
treeb4ecda9841422044bb583026e129624dd47f3c8f /tests/packages.scm
parent9d9e64508186e5f9efbe45302134cd709b25e47b (diff)
downloadguix-18633d4f350160c2eb6f5101a628010322336e91.tar.gz
distro: Move bootstrap packages to (distro packages bootstrap).
* distro/packages/base.scm (glibc-dynamic-linker, %bootstrap-guile,
  bootstrap-origin, package-from-tarball, %bootstrap-base-url,
  %bootstrap-coreutils&co, %bootstrap-binutils, %bootstrap-glibc,
  %bootstrap-gcc, %bootstrap-inputs, package-with-bootstrap-guile): Move
  to ...
* distro/packages/bootstrap.scm: ... here.  New file.
* Makefile.am (MODULES): Add it.
* tests/builders.scm: Use (distro packages bootstrap).
  (%bootstrap-guile): Remove.
* tests/packages.scm: Likewise.
* tests/union.scm: Likewise, and remove @@ to access %bootstrap-inputs.
* tests/derivations.scm: Use (distro packages bootstrap) and remove @@
  to access %bootstrap-coreutils&co.
* HACKING (When the platform is supported by Nixpkgs): Update
  accordingly.
Diffstat (limited to 'tests/packages.scm')
-rw-r--r--tests/packages.scm4
1 files changed, 1 insertions, 3 deletions
diff --git a/tests/packages.scm b/tests/packages.scm
index 7f78e2a248..5838257e09 100644
--- a/tests/packages.scm
+++ b/tests/packages.scm
@@ -26,6 +26,7 @@
   #:use-module (guix build-system gnu)
   #:use-module (distro)
   #:use-module (distro packages base)
+  #:use-module (distro packages bootstrap)
   #:use-module (srfi srfi-26)
   #:use-module (srfi srfi-64)
   #:use-module (ice-9 match))
@@ -44,9 +45,6 @@
   ;; This still involves building GNU Make and GNU Diffutils.
   (@@ (distro packages base) %boot0-inputs))
 
-(define %bootstrap-guile
-  (@@ (distro packages base) %bootstrap-guile))
-
 
 (test-begin "packages")