summary refs log tree commit diff
path: root/tests/profiles.scm
diff options
context:
space:
mode:
authorChris Marusich <cmmarusich@gmail.com>2018-04-08 16:51:42 -0700
committerChris Marusich <cmmarusich@gmail.com>2018-05-08 21:55:46 -0700
commitede121de426f9c56820852888a0b370f0ccbce49 (patch)
treecddd5c464c259d03dd97a021922950f161cfcb13 /tests/profiles.scm
parentb61cb24492c150b5eebb5227f2a7c32e4d42e1d4 (diff)
downloadguix-ede121de426f9c56820852888a0b370f0ccbce49.tar.gz
guix: Separate the package name and version with "@", not "-".
* guix/packages.scm (package-full-name): By default, use "@" to separate
  the package name and package version.  Add an optional delimiter
  argument so that there is still a way to explicitly use a different
  delimiter.
* gnu/packages/commencement.scm (gcc-boot0) <unpack-gmp&co>: Adjust
  accordingly.
* tests/graph.scm: Adjust accordingly.
* tests/profiles.scm: Adjust accordingly.
* NEWS: Mention the change.

Fixes: <https://bugs.gnu.org/31088>.
Reported by Pierre Neidhardt <ambrevar@gmail.com>.
Diffstat (limited to 'tests/profiles.scm')
-rw-r--r--tests/profiles.scm11
1 files changed, 5 insertions, 6 deletions
diff --git a/tests/profiles.scm b/tests/profiles.scm
index 92eb08cb9e..8d3cfe91d3 100644
--- a/tests/profiles.scm
+++ b/tests/profiles.scm
@@ -242,8 +242,8 @@
                                         #:hooks '()
                                         #:locales? #t
                                         #:target target)))
-    (define (find-input name)
-      (let ((name (string-append name ".drv")))
+    (define (find-input package)
+      (let ((name (string-append (package-full-name package "-") ".drv")))
         (any (lambda (input)
                (let ((input (derivation-input-path input)))
                  (and (string-suffix? name input) input)))
@@ -252,12 +252,11 @@
     ;; The inputs for grep and sed should be cross-build derivations, but that
     ;; for the glibc-utf8-locales should be a native build.
     (return (and (string=? (derivation-system drv) (%current-system))
-                 (string=? (find-input (package-full-name packages:grep))
+                 (string=? (find-input packages:grep)
                            (derivation-file-name grep))
-                 (string=? (find-input (package-full-name packages:sed))
+                 (string=? (find-input packages:sed)
                            (derivation-file-name sed))
-                 (string=? (find-input
-                            (package-full-name packages:glibc-utf8-locales))
+                 (string=? (find-input packages:glibc-utf8-locales)
                            (derivation-file-name locales))))))
 
 (test-assert "package->manifest-entry defaults to \"out\""