summary refs log tree commit diff
path: root/tests/simple.sh
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2014-12-17 10:44:19 +0100
committerLudovic Courtès <ludo@gnu.org>2014-12-17 22:57:04 +0100
commitd4e18b05e0ab149265d3d09ae017d7337fc4176f (patch)
treee6faf256d8ec513c85c91684199fa8bf3495f002 /tests/simple.sh
parente7720aa10a1da63bb15a4587837d649268944943 (diff)
downloadguix-d4e18b05e0ab149265d3d09ae017d7337fc4176f.tar.gz
Keep only libstore, nix-daemon, and related stuff.
Diffstat (limited to 'tests/simple.sh')
-rw-r--r--tests/simple.sh25
1 files changed, 0 insertions, 25 deletions
diff --git a/tests/simple.sh b/tests/simple.sh
deleted file mode 100644
index af8bccc2b4..0000000000
--- a/tests/simple.sh
+++ /dev/null
@@ -1,25 +0,0 @@
-source common.sh
-
-drvPath=$(nix-instantiate simple.nix)
-
-test "$(nix-store -q --binding system "$drvPath")" = "$system"
-
-echo "derivation is $drvPath"
-
-outPath=$(nix-store -rvv "$drvPath")
-
-echo "output path is $outPath"
-
-text=$(cat "$outPath"/hello)
-if test "$text" != "Hello World!"; then exit 1; fi
-
-# Directed delete: $outPath is not reachable from a root, so it should
-# be deleteable.
-nix-store --delete $outPath
-if test -e $outPath/hello; then false; fi
-
-outPath="$(NIX_STORE_DIR=/foo nix-instantiate --readonly-mode hash-check.nix)"
-if test "$outPath" != "/foo/lfy1s6ca46rm5r6w4gg9hc0axiakjcnm-dependencies.drv"; then
-    echo "hashDerivationModulo appears broken, got $outPath"
-    exit 1
-fi