summary refs log tree commit diff
path: root/tests/snix.scm
diff options
context:
space:
mode:
authorDavid Thompson <dthompson2@worcester.edu>2014-09-27 10:16:23 -0400
committerDavid Thompson <dthompson2@worcester.edu>2014-09-29 19:30:28 -0400
commit1b3e968512ebbccf02d00c52f7e089156946f445 (patch)
treec45d203439ab9a74d01f2c76850cafb847a755e2 /tests/snix.scm
parent2efb3ddaa434b86a841dffbba89e21d2d9208526 (diff)
downloadguix-1b3e968512ebbccf02d00c52f7e089156946f445.tar.gz
import: Add PyPI importer.
* guix/snix.scm: Delete.
* guix/import/snix.scm: New file.
* guix/import/pypi.scm: New file.
* guix/import/utils.scm: New file.
* guix/scripts/import/nix.scm: New file.
* guix/scripts/import/pypi.scm: New file.
* tests/pypi.scm: New file.
* tests/snix.scm: Import (guix import snix) module.
* guix/scripts/import.scm (%default-options, %options): Delete.
  (%standard-import-options, importers): New variables.
  (show-help): List importers.
  (guix-import): Factor out Nix-specific logic.  Delegate to correct importer
  based upon first argument.
* configure.ac (HAVE_GUILE_JSON): New conditional.
* Makefile.am (MODULES): Add new files and remove 'guix/snix.scm'.
  (SCM_TESTS): Add 'tests/pypi.scm' if guile-json is installed.
Diffstat (limited to 'tests/snix.scm')
-rw-r--r--tests/snix.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/tests/snix.scm b/tests/snix.scm
index 9d692e9c02..2318780d3d 100644
--- a/tests/snix.scm
+++ b/tests/snix.scm
@@ -17,14 +17,14 @@
 ;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
 
 (define-module (test-snix)
-  #:use-module (guix snix)
+  #:use-module (guix import snix)
   #:use-module ((guix utils) #:select (%nixpkgs-directory))
   #:use-module (srfi srfi-1)
   #:use-module (srfi srfi-64)
   #:use-module (ice-9 match))
 
 (define factorize-uri
-  (@@ (guix snix) factorize-uri))
+  (@@ (guix import snix) factorize-uri))
 
 (define-syntax-rule (every? proc lists ...)
   (not (not (every proc lists ...))))