summary refs log tree commit diff
path: root/tests/store.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2013-08-26 22:11:04 +0200
committerLudovic Courtès <ludo@gnu.org>2013-08-26 22:20:27 +0200
commita987d2c02525efd1bf37b4bb5b5df405a06bd15c (patch)
tree65a4e9a5ec464cb3eb4ba2a08ce0656e00a59caa /tests/store.scm
parent3e9066fcfc1fb249eeeb2708d98ae258a38c5b2b (diff)
downloadguix-a987d2c02525efd1bf37b4bb5b5df405a06bd15c.tar.gz
derivations: Move 3 positional parameters into keyword parameters.
* guix/derivations.scm (derivation): Turn `system', `env-vars', and
  `inputs' into keyword parameters.
  (build-expression->derivation): Adjust accordingly.
* gnu/packages/bootstrap.scm (%bootstrap-guile): Likewise.
* tests/derivations.scm, tests/store.scm: Likewise.
* doc/guix.texi (Derivations): Likewise.
Diffstat (limited to 'tests/store.scm')
-rw-r--r--tests/store.scm13
1 files changed, 7 insertions, 6 deletions
diff --git a/tests/store.scm b/tests/store.scm
index 3d5d59b991..9625a6b308 100644
--- a/tests/store.scm
+++ b/tests/store.scm
@@ -80,9 +80,9 @@
 ;;          (b  (add-text-to-store %store "link-builder"
 ;;                                 (format #f "echo ~a > $out" p1)
 ;;                                 '()))
-;;          (d1 (derivation %store "link" (%current-system)
-;;                          "/bin/sh" `("-e" ,b) '()
-;;                          `((,b) (,p1))))
+;;          (d1 (derivation %store "link"
+;;                          "/bin/sh" `("-e" ,b)
+;;                          #:inputs `((,b) (,p1))))
 ;;          (p2 (derivation-path->output-path d1)))
 ;;     (and (add-temp-root %store p2)
 ;;          (build-derivations %store (list d1))
@@ -130,9 +130,10 @@
          (s (add-to-store %store "bash" #t "sha256"
                           (search-bootstrap-binary "bash"
                                                    (%current-system))))
-         (d (derivation %store "the-thing" (%current-system)
-                        s `("-e" ,b) `(("foo" . ,(random-text)))
-                        `((,b) (,s))))
+         (d (derivation %store "the-thing"
+                        s `("-e" ,b)
+                        #:env-vars `(("foo" . ,(random-text)))
+                        #:inputs `((,b) (,s))))
          (o (derivation-path->output-path d)))
     (and (build-derivations %store (list d))
          (equal? (query-derivation-outputs %store d)