summary refs log tree commit diff
path: root/tests
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2013-01-18 01:06:24 +0100
committerLudovic Courtès <ludo@gnu.org>2013-01-18 01:07:31 +0100
commit1ffa7090b99dfd2f54fa883929c5e78d7852657a (patch)
tree1c8bd191e31212e172b3e9158408cccd571a5020 /tests
parent08ba7ff318720d926215de83daed0da628908ca3 (diff)
downloadguix-1ffa7090b99dfd2f54fa883929c5e78d7852657a.tar.gz
distro: Change the module name space to (gnu ...).
* distro: Rename to...
* gnu: ... this.  Update module names accordingly.
* Makefile.am: Adjust accordingly.
* po/POTFILES.in: Likewise.
* distro.scm: Search for files under /gnu/packages instead of
  /distro/packages.
* gnu/packages/base.scm (ld-wrapper-boot3): Likewise.
Diffstat (limited to 'tests')
-rw-r--r--tests/builders.scm4
-rw-r--r--tests/derivations.scm2
-rw-r--r--tests/guix-build.sh8
-rw-r--r--tests/guix-daemon.sh2
-rw-r--r--tests/guix-package.sh4
-rw-r--r--tests/packages.scm6
-rw-r--r--tests/store.scm2
-rw-r--r--tests/union.scm2
8 files changed, 15 insertions, 15 deletions
diff --git a/tests/builders.scm b/tests/builders.scm
index a1e3f8088a..7fafaf5dca 100644
--- a/tests/builders.scm
+++ b/tests/builders.scm
@@ -26,7 +26,7 @@
   #:use-module (guix base32)
   #:use-module (guix derivations)
   #:use-module ((guix packages) #:select (package-derivation))
-  #:use-module (distro packages bootstrap)
+  #:use-module (gnu packages bootstrap)
   #:use-module (ice-9 match)
   #:use-module (srfi srfi-1)
   #:use-module (srfi srfi-64))
@@ -48,7 +48,7 @@
        (map (match-lambda
              ((name package)
               (list name (package-derivation %store package))))
-            (@@ (distro packages base) %boot0-inputs))))
+            (@@ (gnu packages base) %boot0-inputs))))
 
 (define network-reachable?
   (false-if-exception (getaddrinfo "www.gnu.org" "80" AI_NUMERICSERV)))
diff --git a/tests/derivations.scm b/tests/derivations.scm
index 166a917490..21c2a6acd9 100644
--- a/tests/derivations.scm
+++ b/tests/derivations.scm
@@ -24,7 +24,7 @@
   #:use-module (guix base32)
   #:use-module ((guix packages) #:select (package-derivation))
   #:use-module ((distro) #:select (search-bootstrap-binary))
-  #:use-module (distro packages bootstrap)
+  #:use-module (gnu packages bootstrap)
   #:use-module (srfi srfi-1)
   #:use-module (srfi srfi-11)
   #:use-module (srfi srfi-26)
diff --git a/tests/guix-build.sh b/tests/guix-build.sh
index f03afbd494..fccf2168b1 100644
--- a/tests/guix-build.sh
+++ b/tests/guix-build.sh
@@ -27,11 +27,11 @@ if guix-build -e +;
 then false; else true; fi
 
 # Should fail because this is a source-less package.
-if guix-build -e '(@ (distro packages bootstrap) %bootstrap-glibc)' -S
+if guix-build -e '(@ (gnu packages bootstrap) %bootstrap-glibc)' -S
 then false; else true; fi
 
 # Should pass.
-guix-build -e '(@@ (distro packages base) %bootstrap-guile)' |	\
+guix-build -e '(@@ (gnu packages base) %bootstrap-guile)' |	\
     grep -e '-guile-'
 guix-build hello -d |				\
     grep -e '-hello-[0-9\.]\+\.drv$'
@@ -42,11 +42,11 @@ if guix-build hello-0.0.1 -n; then false; else true; fi
 # Keep a symlink to the result, registered as a root.
 result="t-result-$$"
 guix-build -r "$result"					\
-    -e '(@@ (distro packages base) %bootstrap-guile)'
+    -e '(@@ (gnu packages base) %bootstrap-guile)'
 test -x "$result/bin/guile"
 
 # Should fail, because $result already exists.
-if guix-build -r "$result" -e '(@@ (distro packages base) %bootstrap-guile)'
+if guix-build -r "$result" -e '(@@ (gnu packages base) %bootstrap-guile)'
 then false; else true; fi
 
 rm -f "$result"
diff --git a/tests/guix-daemon.sh b/tests/guix-daemon.sh
index ba652b3dce..0d39ff4c24 100644
--- a/tests/guix-daemon.sh
+++ b/tests/guix-daemon.sh
@@ -25,5 +25,5 @@ set -e
 guix-daemon --version
 guix-build --version
 
-guix-build -e '(@ (distro packages bootstrap) %bootstrap-guile)'
+guix-build -e '(@ (gnu packages bootstrap) %bootstrap-guile)'
 guix-build coreutils -n
diff --git a/tests/guix-package.sh b/tests/guix-package.sh
index fc80939646..7b7835dcaa 100644
--- a/tests/guix-package.sh
+++ b/tests/guix-package.sh
@@ -32,7 +32,7 @@ rm -f "$profile"
 
 trap 'rm "$profile" "$profile-"[0-9]* ; rm -rf t-home-'"$$" EXIT
 
-boot_guile="`guix-build -e '(@ (distro packages bootstrap) %bootstrap-guile)'`"
+boot_guile="`guix-build -e '(@ (gnu packages bootstrap) %bootstrap-guile)'`"
 
 guix-package --bootstrap -p "$profile" -i "$boot_guile"
 test -L "$profile" && test -L "$profile-1-link"
@@ -47,7 +47,7 @@ test -f "$profile/bin/guile"
 # Check whether we have network access.
 if guile -c '(getaddrinfo "www.gnu.org" "80" AI_NUMERICSERV)' 2> /dev/null
 then
-    boot_make="`guix-build -e '(@@ (distro packages base) gnu-make-boot0)'`"
+    boot_make="`guix-build -e '(@@ (gnu packages base) gnu-make-boot0)'`"
     guix-package --bootstrap -p "$profile" -i "$boot_make"
     test -L "$profile-2-link"
     test -f "$profile/bin/make" && test -f "$profile/bin/guile"
diff --git a/tests/packages.scm b/tests/packages.scm
index f15f404db6..07d2ea54c7 100644
--- a/tests/packages.scm
+++ b/tests/packages.scm
@@ -25,8 +25,8 @@
   #:use-module (guix build-system trivial)
   #:use-module (guix build-system gnu)
   #:use-module (distro)
-  #:use-module (distro packages base)
-  #:use-module (distro packages bootstrap)
+  #:use-module (gnu packages base)
+  #:use-module (gnu packages bootstrap)
   #:use-module (srfi srfi-26)
   #:use-module (srfi srfi-64)
   #:use-module (rnrs io ports)
@@ -130,7 +130,7 @@
 (test-assert "GNU Make, bootstrap"
   ;; GNU Make is the first program built during bootstrap; we choose it
   ;; here so that the test doesn't last for too long.
-  (let ((gnu-make (@@ (distro packages base) gnu-make-boot0)))
+  (let ((gnu-make (@@ (gnu packages base) gnu-make-boot0)))
     (and (package? gnu-make)
          (or (location? (package-location gnu-make))
              (not (package-location gnu-make)))
diff --git a/tests/store.scm b/tests/store.scm
index 3b3a23489d..c10c035d5d 100644
--- a/tests/store.scm
+++ b/tests/store.scm
@@ -21,7 +21,7 @@
   #:use-module (guix store)
   #:use-module (guix utils)
   #:use-module (guix base32)
-  #:use-module (distro packages bootstrap)
+  #:use-module (gnu packages bootstrap)
   #:use-module (ice-9 match)
   #:use-module (srfi srfi-1)
   #:use-module (srfi srfi-11)
diff --git a/tests/union.scm b/tests/union.scm
index 5bbf992a59..455bdb208d 100644
--- a/tests/union.scm
+++ b/tests/union.scm
@@ -25,7 +25,7 @@
   #:use-module (guix build union)
   #:use-module ((guix build utils)
                 #:select (with-directory-excursion directory-exists?))
-  #:use-module (distro packages bootstrap)
+  #:use-module (gnu packages bootstrap)
   #:use-module (srfi srfi-1)
   #:use-module (srfi srfi-64)
   #:use-module (ice-9 match))