summary refs log tree commit diff
path: root/tests
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2012-12-09 23:52:59 +0100
committerLudovic Courtès <ludo@gnu.org>2012-12-09 23:52:59 +0100
commit3259877d3563ac022633fbd8b73134a10567331e (patch)
tree9958721827f6a8ba3f47333bdfa30a7865db8ee0 /tests
parentd3648e01185dbb3afed85a630b2f8934c68ea143 (diff)
downloadguix-3259877d3563ac022633fbd8b73134a10567331e.tar.gz
store: Add GC-related operations.
* guix/store.scm (gc-action): New enumerate type.
  (read-long-long, read-string-list, write-store-path,
  write-store-path-list, read-store-path-list): New procedures.
  (write-arg): Add support for `store-path' and `store-path-list'.
  (read-arg): Add support for `store-path-list'.
  (define-operation): Add support for multiple-value returns.
  (run-gc, live-paths, dead-paths, collect-garbage, delete-paths): New
  procedures.
  (%long-long-max): New macro.
* tests/store.scm: New file.
* Makefile.am (TESTS): Add it.
Diffstat (limited to 'tests')
-rw-r--r--tests/store.scm87
1 files changed, 87 insertions, 0 deletions
diff --git a/tests/store.scm b/tests/store.scm
new file mode 100644
index 0000000000..71f68a1f23
--- /dev/null
+++ b/tests/store.scm
@@ -0,0 +1,87 @@
+;;; Guix --- Nix package management from Guile.         -*- coding: utf-8 -*-
+;;; Copyright (C) 2012 Ludovic Courtès <ludo@gnu.org>
+;;;
+;;; This file is part of Guix.
+;;;
+;;; Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with Guix.  If not, see <http://www.gnu.org/licenses/>.
+
+
+(define-module (test-store)
+  #:use-module (guix store)
+  #:use-module (guix utils)
+  #:use-module (guix base32)
+  #:use-module (distro packages bootstrap)
+  #:use-module (ice-9 match)
+  #:use-module (srfi srfi-1)
+  #:use-module (srfi srfi-11)
+  #:use-module (srfi srfi-64))
+
+;; Test the (guix store) module.
+
+(define %store
+  (false-if-exception (open-connection)))
+
+(when %store
+  ;; Make sure we build everything by ourselves.
+  (set-build-options %store #:use-substitutes? #f))
+
+(define %seed
+  (seed->random-state (logxor (getpid) (car (gettimeofday)))))
+
+(define (random-text)
+  (number->string (random (expt 2 256) %seed) 16))
+
+
+(test-begin "store")
+
+(test-skip (if %store 0 10))
+
+(test-assert "dead-paths"
+  (let ((p (add-text-to-store %store "random-text"
+                              (random-text) '())))
+    (member p (dead-paths %store))))
+
+;; FIXME: Find a test for `live-paths'.
+;;
+;; (test-assert "temporary root is in live-paths"
+;;   (let* ((p1 (add-text-to-store %store "random-text"
+;;                                 (random-text) '()))
+;;          (b  (add-text-to-store %store "link-builder"
+;;                                 (format #f "echo ~a > $out" p1)
+;;                                 '()))
+;;          (d1 (derivation %store "link" (%current-system)
+;;                          "/bin/sh" `("-e" ,b) '()
+;;                          `((,b) (,p1))))
+;;          (p2 (derivation-path->output-path d1)))
+;;     (and (add-temp-root %store p2)
+;;          (build-derivations %store (list d1))
+;;          (valid-path? %store p1)
+;;          (member (pk p2) (live-paths %store)))))
+
+(test-assert "dead path can be explicitly collected"
+  (let ((p (add-text-to-store %store "random-text"
+                              (random-text) '())))
+    (let-values (((paths freed) (delete-paths %store (list p))))
+      (and (equal? paths (list p))
+           (> freed 0)
+           (not (file-exists? p))))))
+
+(test-end "store")
+
+
+(exit (= (test-runner-fail-count (test-runner-current)) 0))
+
+;;; Local Variables:
+;;; eval: (put 'test-assert 'scheme-indent-function 1)
+;;; End: