summary refs log tree commit diff
path: root/tests
diff options
context:
space:
mode:
authorAlex Kost <alezost@gmail.com>2017-03-20 13:41:41 +0300
committerAlex Kost <alezost@gmail.com>2017-03-27 10:55:16 +0300
commit689db38e3467f66725e8841eac72225110a75a17 (patch)
tree1b357ea14f3761f7d4c361c1204815cd99d4df54 /tests
parent2fccc0d193497eb2ee3127270dea12be103f1bc2 (diff)
downloadguix-689db38e3467f66725e8841eac72225110a75a17.tar.gz
ui: Support Texinfo markup in package synopses.
* guix/ui.scm (package-field-string): New procedure.
(package-description-string): Use it.
(package-synopsis-string): New procedure.
(package->recutils): Use it.
* guix/scripts/lint.scm (check-synopsis-style)[check-texinfo-markup]:
New procedure.  Use it in checks.
* tests/lint.scm: Test it.
* gnu/packages/perl.scm (perl-try-tiny)[synopsis]: Adjust for the
Texinfo markup.
Diffstat (limited to 'tests')
-rw-r--r--tests/lint.scm8
1 files changed, 8 insertions, 0 deletions
diff --git a/tests/lint.scm b/tests/lint.scm
index 3a9b89fe95..7610a91fd3 100644
--- a/tests/lint.scm
+++ b/tests/lint.scm
@@ -4,6 +4,7 @@
 ;;; Copyright © 2014, 2015, 2016 Ludovic Courtès <ludo@gnu.org>
 ;;; Copyright © 2015, 2016 Mathieu Lirzin <mthl@gnu.org>
 ;;; Copyright © 2016 Hartmut Goebel <h.goebel@crazy-compilers.com>
+;;; Copyright © 2017 Alex Kost <alezost@gmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -167,6 +168,13 @@
                         (check-synopsis-style pkg)))
                     "synopsis should not be empty")))
 
+(test-assert "synopsis: valid Texinfo markup"
+  (->bool
+   (string-contains
+    (with-warnings
+      (check-synopsis-style (dummy-package "x" (synopsis "Bad $@ texinfo"))))
+    "Texinfo markup in synopsis is invalid")))
+
 (test-assert "synopsis: does not start with an upper-case letter"
   (->bool
    (string-contains (with-warnings