summary refs log tree commit diff
path: root/tests
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2012-11-04 22:04:41 +0100
committerLudovic Courtès <ludo@gnu.org>2012-11-04 22:04:41 +0100
commit18633d4f350160c2eb6f5101a628010322336e91 (patch)
treeb4ecda9841422044bb583026e129624dd47f3c8f /tests
parent9d9e64508186e5f9efbe45302134cd709b25e47b (diff)
downloadguix-18633d4f350160c2eb6f5101a628010322336e91.tar.gz
distro: Move bootstrap packages to (distro packages bootstrap).
* distro/packages/base.scm (glibc-dynamic-linker, %bootstrap-guile,
  bootstrap-origin, package-from-tarball, %bootstrap-base-url,
  %bootstrap-coreutils&co, %bootstrap-binutils, %bootstrap-glibc,
  %bootstrap-gcc, %bootstrap-inputs, package-with-bootstrap-guile): Move
  to ...
* distro/packages/bootstrap.scm: ... here.  New file.
* Makefile.am (MODULES): Add it.
* tests/builders.scm: Use (distro packages bootstrap).
  (%bootstrap-guile): Remove.
* tests/packages.scm: Likewise.
* tests/union.scm: Likewise, and remove @@ to access %bootstrap-inputs.
* tests/derivations.scm: Use (distro packages bootstrap) and remove @@
  to access %bootstrap-coreutils&co.
* HACKING (When the platform is supported by Nixpkgs): Update
  accordingly.
Diffstat (limited to 'tests')
-rw-r--r--tests/builders.scm4
-rw-r--r--tests/derivations.scm6
-rw-r--r--tests/packages.scm4
-rw-r--r--tests/union.scm6
4 files changed, 6 insertions, 14 deletions
diff --git a/tests/builders.scm b/tests/builders.scm
index d79603f7da..8b0fa117a9 100644
--- a/tests/builders.scm
+++ b/tests/builders.scm
@@ -25,6 +25,7 @@
   #:use-module (guix utils)
   #:use-module (guix derivations)
   #:use-module ((guix packages) #:select (package-derivation))
+  #:use-module (distro packages bootstrap)
   #:use-module (ice-9 match)
   #:use-module (srfi srfi-1)
   #:use-module (srfi srfi-64))
@@ -48,9 +49,6 @@
               (list name (package-derivation %store package))))
             (@@ (distro packages base) %boot0-inputs))))
 
-(define %bootstrap-guile
-  (@@ (distro packages base) %bootstrap-guile))
-
 
 (test-begin "builders")
 
diff --git a/tests/derivations.scm b/tests/derivations.scm
index 02f0a9b2a1..684dac4d6f 100644
--- a/tests/derivations.scm
+++ b/tests/derivations.scm
@@ -22,7 +22,7 @@
   #:use-module (guix store)
   #:use-module (guix utils)
   #:use-module ((guix packages) #:select (package-derivation))
-  #:use-module ((distro packages base) #:select (%bootstrap-guile))
+  #:use-module (distro packages bootstrap)
   #:use-module (srfi srfi-1)
   #:use-module (srfi srfi-11)
   #:use-module (srfi srfi-26)
@@ -209,9 +209,7 @@
 
 (define %coreutils
   (false-if-exception
-   (or (package-derivation %store
-                           (@@ (distro packages base)
-                               %bootstrap-coreutils&co))
+   (or (package-derivation %store %bootstrap-coreutils&co)
        (nixpkgs-derivation "coreutils"))))
 
 (test-skip (if %coreutils 0 1))
diff --git a/tests/packages.scm b/tests/packages.scm
index 7f78e2a248..5838257e09 100644
--- a/tests/packages.scm
+++ b/tests/packages.scm
@@ -26,6 +26,7 @@
   #:use-module (guix build-system gnu)
   #:use-module (distro)
   #:use-module (distro packages base)
+  #:use-module (distro packages bootstrap)
   #:use-module (srfi srfi-26)
   #:use-module (srfi srfi-64)
   #:use-module (ice-9 match))
@@ -44,9 +45,6 @@
   ;; This still involves building GNU Make and GNU Diffutils.
   (@@ (distro packages base) %boot0-inputs))
 
-(define %bootstrap-guile
-  (@@ (distro packages base) %bootstrap-guile))
-
 
 (test-begin "packages")
 
diff --git a/tests/union.scm b/tests/union.scm
index f8a58d5952..73b95c49b8 100644
--- a/tests/union.scm
+++ b/tests/union.scm
@@ -25,6 +25,7 @@
   #:use-module (guix build union)
   #:use-module ((guix build utils)
                 #:select (with-directory-excursion directory-exists?))
+  #:use-module (distro packages bootstrap)
   #:use-module (srfi srfi-64)
   #:use-module (ice-9 match))
 
@@ -33,9 +34,6 @@
 (define %store
   (false-if-exception (open-connection)))
 
-(define %bootstrap-guile
-  (@@ (distro packages base) %bootstrap-guile))
-
 (when %store
   ;; By default, use %BOOTSTRAP-GUILE for the current system.
   (let ((drv (package-derivation %store %bootstrap-guile)))
@@ -72,7 +70,7 @@
   (let* ((inputs  (map (match-lambda
                         ((name package)
                          `(,name ,(package-derivation %store package))))
-                       (@@ (distro packages base) %bootstrap-inputs)))
+                       %bootstrap-inputs))
          (builder `(begin
                      (use-modules (guix build union))
                      (union-build (assoc-ref %outputs "out")