summary refs log tree commit diff
path: root/tests
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2020-08-24 16:26:14 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2020-08-25 13:45:27 -0400
commit4b5a6fbc9b754c0ca70d033dd99f17c4f028733a (patch)
tree7e1267a5ab1edc10d1b4dd71e51a80f17c8fba36 /tests
parenta5ccf1b522b443fa2aab79a4833810bdede4a9ff (diff)
downloadguix-4b5a6fbc9b754c0ca70d033dd99f17c4f028733a.tar.gz
offload: Modify the build-machine record to accept multiple systems.
* guix/scripts/offload.scm (<build-machine>)[systems]: New field.
[system]: Accessor changed to %build-machine-system.  Default to #f.
* guix/scripts/offload.scm (build-machine-system): Wrap %build-machine-system
with a deprecation warning.
(build-machine-systems): Access the new systems field or fallback to use
build-machine-system, for backward compatibility.
(machine-matches?): Adjust.
* tests/offload.scm: Add tests...
* Makefile.am (SCM_TESTS): ...and register them.
* doc/guix.texi (Daemon Offload Setup): Update doc.
Diffstat (limited to 'tests')
-rw-r--r--tests/offload.scm71
1 files changed, 71 insertions, 0 deletions
diff --git a/tests/offload.scm b/tests/offload.scm
new file mode 100644
index 0000000000..5a5de4e8b9
--- /dev/null
+++ b/tests/offload.scm
@@ -0,0 +1,71 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2020 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (tests offload)
+  #:use-module (guix scripts offload)
+  #:use-module (srfi srfi-64))
+
+
+(test-begin "offload")
+
+(define-syntax-rule (expose-internal-definitions s1 s2 ...)
+  (begin
+    (define s1 (@@ (guix scripts offload) s1))
+    (define s2 (@@ (guix scripts offload) s2)) ...))
+
+(expose-internal-definitions machine-matches?
+                             build-requirements-system
+                             build-requirements-features
+                             build-machine-system
+                             build-machine-systems
+                             %build-machine-system
+                             %build-machine-systems
+                             build-machine-features)
+
+(define (deprecated-build-machine system)
+  (build-machine
+   (name "m1")
+   (user "dummy")
+   (host-key "some-key")
+   (system system)))
+
+(define (new-build-machine systems)
+  (build-machine
+   (name "m1")
+   (user "dummy")
+   (host-key "some-key")
+   (systems systems)))
+
+;;; Test that deprecated build-machine definitions still work.
+(test-assert (machine-matches? (deprecated-build-machine "i686-linux")
+                               (build-requirements
+                                (system "i686-linux"))))
+
+
+(test-assert (machine-matches? (new-build-machine '("i686-linux"))
+                               (build-requirements
+                                (system "i686-linux"))))
+
+;;; A build machine can act as more than one system type, thanks to QEMU
+;;; emulation.
+(test-assert (machine-matches? (new-build-machine '("armhf-linux"
+                                                    "aarch64-linux"
+                                                    "i686-linux"
+                                                    "x86_64-linux"))
+                               (build-requirements
+                                (system "armhf-linux"))))