summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/haskell.scm7
1 files changed, 5 insertions, 2 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index c6efdadfac..c1c6fd740b 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -538,9 +538,12 @@ interactive environment for the functional language Haskell.")
                   (("^SHELL.*=.*/bin/sh") (string-append "SHELL = " bash)))
                 (substitute* "aclocal.m4"
                   (("SHELL=/bin/sh") (string-append "SHELL=" bash)))
-                (substitute* '"compiler/Makefile"
+                (substitute* "compiler/Makefile"
                   (("#!/bin/sh") (string-append "#!" bash)))
-                (substitute* "libraries/base/cbits/execvpe.c"
+                (substitute* '("libraries/base/cbits/execvpe.c"
+                               "libraries/Cabal/Distribution/attic"
+                               "libraries/Cabal/Distribution/Simple/Register.hs"
+                               "libraries/base/System/Process/Internals.hs")
                   (("/bin/sh") bash)
                   (("\"sh\"") (string-append "\"" bash "\"")))