summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/gcc.scm4
1 files changed, 4 insertions, 0 deletions
diff --git a/gnu/packages/gcc.scm b/gnu/packages/gcc.scm
index 30b2be1f5a..ea9b9e57f4 100644
--- a/gnu/packages/gcc.scm
+++ b/gnu/packages/gcc.scm
@@ -778,6 +778,10 @@ It also includes runtime support libraries for these languages.")
                        (("/lib/ld\\.so\\.1")
                         (search-input-file
                           inputs #$(glibc-dynamic-linker matching-system))))
+                     (substitute* "gcc/config/i386/gnu.h"
+                       (("/lib/ld\\.so")
+                        (search-input-file
+                          inputs #$(glibc-dynamic-linker matching-system))))
                      (substitute* '("gcc/config/alpha/linux-elf.h"
                                     "gcc/config/arm/linux-elf.h"
                                     "gcc/config/i386/linux.h"