summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/gnome.scm2
1 files changed, 2 insertions, 0 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index bb503fb371..f4e7b76a27 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -6209,9 +6209,11 @@ discovery protocols.")
           'install 'wrap-totem
           (lambda* (#:key inputs outputs #:allow-other-keys)
             (let ((out             (assoc-ref outputs "out"))
+                  (gi-typelib-path (getenv "GI_TYPELIB_PATH"))
                   (gst-plugin-path (getenv "GST_PLUGIN_SYSTEM_PATH"))
                   (grl-plugin-path (getenv "GRL_PLUGIN_PATH")))
               (wrap-program (string-append out "/bin/totem")
+                `("GI_TYPELIB_PATH"        ":" suffix (,gi-typelib-path))
                 `("GST_PLUGIN_SYSTEM_PATH" ":" prefix (,gst-plugin-path))
                 `("GRL_PLUGIN_PATH"        ":" prefix (,grl-plugin-path)))
               (wrap-program (string-append out "/bin/totem-video-thumbnailer")