summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/bioinformatics.scm10
1 files changed, 4 insertions, 6 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 1c7df0e811..9039439f32 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -4876,7 +4876,7 @@ experiments.")
 (define-public macs
   (package
     (name "macs")
-    (version "2.2.6")
+    (version "2.2.7.1")
     (source (origin
               ;; The PyPi tarball does not contain tests.
               (method git-fetch)
@@ -4886,7 +4886,7 @@ experiments.")
               (file-name (git-file-name name version))
               (sha256
                (base32
-                "1c5gxr0mk6hkd4vclf0k00wvyvzw2vrmk52c85338p7aqjwg6n15"))
+                "08zsgh65xbpv1md2s3wqmrk9g2mz6izmn59ryw5lbac54120p291"))
         (modules '((guix build utils)))
         ;; Remove files generated by Cython
         (snippet
@@ -4897,8 +4897,7 @@ experiments.")
                           (when (file-exists? generated-file)
                             (delete-file generated-file))))
                       (find-files "." "\\.pyx$"))
-            (delete-file "MACS2/IO/CallPeakUnitPrecompiled.c")
-            #t))))
+            (delete-file "MACS2/IO/CallPeakUnitPrecompiled.c")))))
     (build-system python-build-system)
     (arguments
      `(#:phases
@@ -4907,8 +4906,7 @@ experiments.")
            (lambda* (#:key tests? inputs outputs #:allow-other-keys)
              (when tests?
                (add-installed-pythonpath inputs outputs)
-               (invoke "pytest" "-v"))
-             #t)))))
+               (invoke "pytest" "-v")))))))
     (inputs
      `(("python-numpy" ,python-numpy)))
     (native-inputs