summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/cups.scm6
1 files changed, 5 insertions, 1 deletions
diff --git a/gnu/packages/cups.scm b/gnu/packages/cups.scm
index 5791d4994a..a707006c3b 100644
--- a/gnu/packages/cups.scm
+++ b/gnu/packages/cups.scm
@@ -201,9 +201,11 @@ driver is known to work with these printers:
                       (wrap-program file
                         `("PATH" ":" prefix
                           (,(string-append
+                             #$(this-package-input "coreutils") "/bin:"
                              #$(this-package-input "ghostscript-with-cups")
                              "/bin:"
-                             #$(this-package-input "grep") "/bin")))))
+                             #$(this-package-input "grep") "/bin:"
+                             #$(this-package-input "sed") "/bin")))))
                     (find-files (string-append #$output
                                                "/lib/cups/filter"))))))))
     (native-inputs
@@ -211,6 +213,7 @@ driver is known to work with these printers:
            pkg-config))
     (inputs
      (list avahi
+           coreutils
            fontconfig
            freetype
            font-dejavu                  ; also needed by test suite
@@ -225,6 +228,7 @@ driver is known to work with these printers:
            glib
            qpdf
            poppler
+           sed
            cups-minimal))
     (home-page "https://wiki.linuxfoundation.org/openprinting/cups-filters")
     (synopsis "OpenPrinting CUPS filters and backends")