summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--gnu/installer.scm6
-rw-r--r--gnu/installer/newt.scm14
-rw-r--r--gnu/installer/newt/keymap.scm8
-rw-r--r--gnu/installer/newt/parameters.scm (renamed from gnu/installer/newt/help.scm)15
-rw-r--r--gnu/installer/record.scm8
-rw-r--r--gnu/local.mk2
-rw-r--r--po/guix/POTFILES.in2
7 files changed, 28 insertions, 27 deletions
diff --git a/gnu/installer.scm b/gnu/installer.scm
index 75c5a01570..6cd3995e51 100644
--- a/gnu/installer.scm
+++ b/gnu/installer.scm
@@ -198,11 +198,11 @@ selected keymap."
         (timezone-data #~(string-append #$tzdata
                                         "/share/zoneinfo/zone.tab")))
     #~(lambda (current-installer)
-        ((installer-help-menu current-installer)
+        ((installer-parameters-menu current-installer)
          (lambda ()
-           ((installer-help-page current-installer)
+           ((installer-parameters-page current-installer)
             (lambda _
-              (#$(compute-keymap-step 'help)
+              (#$(compute-keymap-step 'param)
                current-installer)))))
         (list
          ;; Ask the user to choose a locale among those supported by
diff --git a/gnu/installer/newt.scm b/gnu/installer/newt.scm
index 7ac015eaad..a24a152984 100644
--- a/gnu/installer/newt.scm
+++ b/gnu/installer/newt.scm
@@ -21,7 +21,7 @@
   #:use-module (gnu installer utils)
   #:use-module (gnu installer newt ethernet)
   #:use-module (gnu installer newt final)
-  #:use-module (gnu installer newt help)
+  #:use-module (gnu installer newt parameters)
   #:use-module (gnu installer newt hostname)
   #:use-module (gnu installer newt keymap)
   #:use-module (gnu installer newt locale)
@@ -47,7 +47,7 @@
   (clear-screen)
   (set-screen-size!)
   (push-help-line
-   (format #f (G_ "Press <F1> for help."))))
+   (format #f (G_ "Press <F1> for installation parameters."))))
 
 (define (exit)
   (newt-finish)
@@ -112,11 +112,11 @@ problem. The backtrace is displayed below. Please report it by email to \
 (define (services-page)
   (run-services-page))
 
-(define (help-menu menu-proc)
+(define (parameters-menu menu-proc)
   (newt-set-help-callback menu-proc))
 
-(define (help-page keyboard-layout-selection)
-  (run-help-page keyboard-layout-selection))
+(define (parameters-page keyboard-layout-selection)
+  (run-parameters-page keyboard-layout-selection))
 
 (define newt-installer
   (installer
@@ -135,5 +135,5 @@ problem. The backtrace is displayed below. Please report it by email to \
    (partition-page partition-page)
    (services-page services-page)
    (welcome-page welcome-page)
-   (help-menu help-menu)
-   (help-page help-page)))
+   (parameters-menu parameters-menu)
+   (parameters-page parameters-page)))
diff --git a/gnu/installer/newt/keymap.scm b/gnu/installer/newt/keymap.scm
index 0147a0b9d5..8625afaa03 100644
--- a/gnu/installer/newt/keymap.scm
+++ b/gnu/installer/newt/keymap.scm
@@ -39,21 +39,21 @@
      #:title title
      #:info-text
      (case context
-       ((help) (G_ "Please choose your keyboard layout. \
+       ((param) (G_ "Please choose your keyboard layout. \
 It will only be used during the installation process."))
        (else (G_ "Please choose your keyboard layout. \
 It will be used during the install process, and for the installed system. \
-You can switch to different layout at any time from the help menu.")))
+You can switch to different layout at any time from the parameters menu.")))
      #:listbox-items layouts
      #:listbox-item->text layout->text
      #:sort-listbox-items? #f
      #:button-text
      (case context
-       ((help) (G_ "Continue"))
+       ((param) (G_ "Continue"))
        (else (G_ "Exit")))
      #:button-callback-procedure
      (case context
-       ((help) (const #t))
+       ((param) (const #t))
        (else
         (lambda _
           (raise
diff --git a/gnu/installer/newt/help.scm b/gnu/installer/newt/parameters.scm
index a488f5fa2a..4a34e94155 100644
--- a/gnu/installer/newt/help.scm
+++ b/gnu/installer/newt/parameters.scm
@@ -16,28 +16,29 @@
 ;;; You should have received a copy of the GNU General Public License
 ;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
 
-(define-module (gnu installer newt help)
+(define-module (gnu installer newt parameters)
   #:use-module (gnu installer steps)
   #:use-module (gnu installer newt page)
   #:use-module (guix i18n)
   #:use-module (ice-9 match)
   #:use-module (newt)
-  #:export (run-help-page))
+  #:export (run-parameters-page))
 
-(define (run-help-page keyboard-layout-selection)
-  "Run a help page allowing to change the keyboard layout"
+(define (run-parameters-page keyboard-layout-selection)
+  "Run a parameters page allowing to change the keyboard layout"
   (let* ((items
           (list
            (cons (G_ "Change keyboard layout") keyboard-layout-selection)))
          (result
           (run-listbox-selection-page
-           #:info-text (G_ "This is the help menu, please choose an action.")
-           #:title (G_ "Installation help")
+           #:info-text (G_ "Please choose one of the following parameters or \
+press ‘Back’ to go back to the installation process.")
+           #:title (G_ "Installation parameters")
            #:listbox-items items
            #:listbox-item->text car
            #:sort-listbox-items? #f
            #:listbox-height 6
-           #:button-text (G_ "Continue"))))
+           #:button-text (G_ "Back"))))
     (match result
       ((_ . proc)
        (proc))
diff --git a/gnu/installer/record.scm b/gnu/installer/record.scm
index 78acf50c63..7bc22e90e0 100644
--- a/gnu/installer/record.scm
+++ b/gnu/installer/record.scm
@@ -38,8 +38,8 @@
             installer-partition-page
             installer-services-page
             installer-welcome-page
-            installer-help-menu
-            installer-help-page))
+            installer-parameters-menu
+            installer-parameters-page))
 
 
 ;;;
@@ -85,6 +85,6 @@
   ;; procedure (logo) -> void
   (welcome-page installer-welcome-page)
   ;; procedure (menu-proc) -> void
-  (help-menu installer-help-menu)
+  (parameters-menu installer-parameters-menu)
   ;; procedure (keyboard-layout-selection) -> void
-  (help-page installer-help-page))
+  (parameters-page installer-parameters-page))
diff --git a/gnu/local.mk b/gnu/local.mk
index d177faf106..3757f7d6e1 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -672,7 +672,7 @@ INSTALLER_MODULES =                             \
 						\
   %D%/installer/newt/ethernet.scm		\
   %D%/installer/newt/final.scm  		\
-  %D%/installer/newt/help.scm			\
+  %D%/installer/newt/parameters.scm		\
   %D%/installer/newt/hostname.scm		\
   %D%/installer/newt/keymap.scm			\
   %D%/installer/newt/locale.scm			\
diff --git a/po/guix/POTFILES.in b/po/guix/POTFILES.in
index 4cc4fe7b31..77332e7b17 100644
--- a/po/guix/POTFILES.in
+++ b/po/guix/POTFILES.in
@@ -16,7 +16,7 @@ gnu/installer/locale.scm
 gnu/installer/newt.scm
 gnu/installer/newt/ethernet.scm
 gnu/installer/newt/final.scm
-gnu/installer/newt/help.scm
+gnu/installer/newt/parameters.scm
 gnu/installer/newt/hostname.scm
 gnu/installer/newt/keymap.scm
 gnu/installer/newt/locale.scm