summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/samba.scm8
1 files changed, 8 insertions, 0 deletions
diff --git a/gnu/packages/samba.scm b/gnu/packages/samba.scm
index ce707a8912..bf92b210c3 100644
--- a/gnu/packages/samba.scm
+++ b/gnu/packages/samba.scm
@@ -322,6 +322,14 @@ Desktops into Active Directory environments using the winbind daemon.")
     (arguments
      '(#:phases
        (modify-phases %standard-phases
+         (add-after 'unpack 'remove-crypt-reference
+           ;; The following is needed because Python.h propagates
+           ;; HAVE_CRYPT_H, which is then seen from lib/replace/ but talloc
+           ;; doesn't need it at all.
+           (lambda _
+             (substitute* "lib/replace/replace.h"
+               (("#include <crypt.h>")
+                ""))))
          (replace 'configure
            (lambda* (#:key outputs #:allow-other-keys)
              ;; talloc uses a custom configuration script that runs a Python