summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/emacs.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index c3badab852..d8f5ce17dd 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -8405,3 +8405,24 @@ made of parentheses, brackets, and braces according to their depth.  Each
 successive level is highlighted in a different color.  This makes it easy to
 orient yourself in the code, and tell which statements are at a given level.")
       (license license:gpl3+))))
+
+(define-public emacs-hierarchy
+  (package
+    (name "emacs-hierarchy")
+    (version "0.7.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "https://github.com/DamienCassou/hierarchy/archive/"
+             "v" version ".tar.gz"))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32
+         "1a463v5zk6zis2p8cs4mads3iyxh266yahi6j6y0paggfl2yhkc8"))))
+    (build-system emacs-build-system)
+    (home-page "https://github.com/DamienCassou/hierarchy")
+    (synopsis "Library to create and display hierarchy structures")
+    (description "This package provides an Emacs library to create, query,
+navigate and display hierarchy structures.")
+    (license license:gpl3+)))