summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--guix/build-system/meson.scm6
1 files changed, 2 insertions, 4 deletions
diff --git a/guix/build-system/meson.scm b/guix/build-system/meson.scm
index 529a2b8b0f..88a7b58286 100644
--- a/guix/build-system/meson.scm
+++ b/guix/build-system/meson.scm
@@ -86,8 +86,7 @@
                          ;; to avoid superfluous entries in RUNPATH as described
                          ;; in <https://bugs.gnu.org/28444#46>, so armhf may now
                          ;; have different runtime dependencies from other arches.
-                         ,@(if (not (string-prefix? "arm" (or (%current-target-system)
-                                                              (%current-system))))
+                         ,@(if (not (target-arm32?))
                                `(("patchelf" ,(default-patchelf)))
                                '())
                          ,@native-inputs))
@@ -148,8 +147,7 @@ has a 'meson.build' file."
                     #:search-paths ',(map search-path-specification->sexp
                                           search-paths)
                     #:phases
-                    (if (string-prefix? "arm" ,(or (%current-target-system)
-                                                   (%current-system)))
+                    (if (target-arm32?)
                         (modify-phases build-phases (delete 'fix-runpath))
                         build-phases)
                     #:configure-flags ,configure-flags