summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/python-xyz.scm15
1 files changed, 5 insertions, 10 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 1a804f165b..c3dfb9603c 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -31161,20 +31161,15 @@ module patches @code{asyncio} to allow nested use of @code{asyncio.run} and
          (base32 "0drvqxbr6fpydb4d7z5dhn97d578gf39sd8cawyl6ksf1f4y8yzg"))))
     (build-system pyproject-build-system)
     (arguments
-     `(#:tests? #f  ; Test suite can't find aiohttp.
-       #:phases
-       (modify-phases %standard-phases
-         (replace 'check
-           (lambda* (#:key inputs outputs tests? #:allow-other-keys)
-             (when tests?
-               (add-installed-pythonpath inputs outputs)
-               (invoke "pytest" "--maxfail" "3" "--verbose"))
-             #t)))))
+     (list
+      #:test-flags '(list "-n" (number->string (parallel-job-count)))))
     (native-inputs
      (list python-aiohttp
            python-hatchling
+           python-psutil
            python-pytest
-           python-pytest-asyncio))
+           python-pytest-asyncio
+           python-pytest-xdist))
     (home-page "https://github.com/yuvipanda/simpervisor")
     (synopsis "Simple async process supervisor")
     (description