summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/maths.scm7
1 files changed, 7 insertions, 0 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 7b43a8cbe8..8e287a8055 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -3092,6 +3092,7 @@ scientific applications modeled by partial differential equations.")
        ("openmpi" ,openmpi)
        ("scalapack" ,scalapack)
        ("scotch" ,pt-scotch32)
+       ("scotch" ,pt-scotch32 "metis")
        ,@(package-inputs petsc)))
     (arguments
      (substitute-keyword-arguments (package-arguments petsc)
@@ -3111,6 +3112,12 @@ scientific applications modeled by partial differential equations.")
             ,@(delete "--with-mpi=0" #$cf)))
        ((#:phases phases)
         #~(modify-phases #$phases
+            (add-before 'configure 'adjust-pt-scotch-library-names
+              (lambda _
+                ;; Adjust to the library name changes in Scotch 7.0.
+                (substitute* "config/BuildSystem/config/packages/PTScotch.py"
+                  (("libptesmumps") "libesmumps")
+                  (("libptscotchparmetis") "libptscotchparmetisv3"))))
             (add-before 'configure 'mpi-setup
               #$%openmpi-setup)))))
     (synopsis "Library to solve PDEs (with MUMPS and MPI support)")))