summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/aux-files/emacs/guix-emacs.el18
1 files changed, 11 insertions, 7 deletions
diff --git a/gnu/packages/aux-files/emacs/guix-emacs.el b/gnu/packages/aux-files/emacs/guix-emacs.el
index c253e64df8..265c8bde16 100644
--- a/gnu/packages/aux-files/emacs/guix-emacs.el
+++ b/gnu/packages/aux-files/emacs/guix-emacs.el
@@ -32,10 +32,14 @@
 
 (defvar guix-emacs-autoloads-regexp
   (rx (* any) "-autoloads.el" (zero-or-one "c") string-end)
-  "Regexp to match Emacs 'autoloads' file.")
+  "Regexp to match files containing autoload definitions.
+
+Historically, this used to be the package name followed by \"-autoloads.el\".
+As of Emacs 29, the term \"loaddefs\" is preferred over \"autoloads\",
+but they function much in the same manner.")
 
 (defun guix-emacs-find-autoloads (directory)
-  "Return a list of Emacs 'autoloads' files in DIRECTORY.
+  "Return a list of files containing autoload definitions in DIRECTORY.
 The files in the list do not have extensions (.el, .elc)."
   ;; `directory-files' doesn't honor group in regexp.
   (delete-dups (mapcar #'file-name-sans-extension
@@ -66,12 +70,12 @@ The files in the list do not have extensions (.el, .elc)."
 
 ;;;###autoload
 (defun guix-emacs-autoload-packages (&optional no-reload)
-  "Autoload Emacs packages found in EMACSLOADPATH.
+  "Load autoload definitions for packages in `load-path'.
 
-'Autoload' means to load the 'autoloads' files matching
-`guix-emacs-autoloads-regexp'.  By default, the subdirs.el files
-found on the load path are reloaded to discover newly installed
-packages, unless NO-RELOAD is provided."
+Autoload definitions are contained within files matching
+`guix-emacs-autoload-regexp'; load each file matching that regexp.
+When NO-RELOAD is nil (the default), also evaluate any subdirs.el files
+found in `load-path' to discover newly installed packages."
   (interactive "P")
   ;; Reload the subdirs.el files such as the one generated by the Guix profile
   ;; hook, so that newly installed Emacs packages located under