summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/patches/biber-sortinithash.patch9
-rw-r--r--gnu/packages/tex.scm7
2 files changed, 14 insertions, 2 deletions
diff --git a/gnu/packages/patches/biber-sortinithash.patch b/gnu/packages/patches/biber-sortinithash.patch
index 1f054d25e4..5a626705e6 100644
--- a/gnu/packages/patches/biber-sortinithash.patch
+++ b/gnu/packages/patches/biber-sortinithash.patch
@@ -21,6 +21,15 @@ index b4f641e..c6f86c7 100644
        \field{labelnamesource}{author}
        \field{labeltitlesource}{title}
        \field{title}{The Title}
+@@ -116,7 +116,7 @@ my $ann2 = q|    \entry{ann2}{misc}{}
+       \strng{authorfullhash}{90ae96c82de92e36949bc64254bbde0c}
+       \field{extraname}{2}
+       \field{sortinit}{L}
+-      \field{sortinithash}{2c7981aaabc885868aba60f0c09ee20f}
++      \field{sortinithash}{dad3efd0836470093a7b4a7bb756eb8c}
+       \field{labelnamesource}{author}
+       \field{labeltitlesource}{title}
+       \field{title}{The Title}
 diff --git a/t/basic-misc.t b/t/basic-misc.t
 index d4664b1..a9168cc 100644
 --- a/t/basic-misc.t
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 683f9d7283..137e000bc5 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -5916,8 +5916,11 @@ values (strings, macros, or numbers) pasted together.")
 
 (define-public biber
   (package
+    ;; Note: When updating Biber, make sure it matches our BibLaTeX version by
+    ;; checking the Biber/BibLaTeX compatibility matrix in the BibLaTeX manual
+    ;; at <https://ctan.org/pkg/biblatex>.
     (name "biber")
-    (version "2.11")
+    (version "2.12")
     (source (origin
               (method git-fetch)
               (uri (git-reference
@@ -5930,7 +5933,7 @@ values (strings, macros, or numbers) pasted together.")
                                        "biber-sortinithash.patch"))
               (sha256
                (base32
-                "0qgkc1k9n36yfmndwz879pak6mjphld0p85lzn9g2ng0vhxsifzz"))))
+                "1g1hi6zvf2hmrjly1sidjaxy5440gfqm4p7p3n7kayshnjsmlskx"))))
     (build-system perl-build-system)
     (arguments
      `(#:phases