summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/python-xyz.scm15
1 files changed, 13 insertions, 2 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index c576d2106a..a4d86ace92 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -1388,10 +1388,21 @@ HDF5 library from Python.  The low-level interface is intended to be a
 complete wrapping of the HDF5 API, while the high-level component supports
 access to HDF5 files, datasets and groups using established Python and NumPy
 concepts.")
-    (license license:bsd-3)))
+    (license license:bsd-3)
+    (properties `((python2-variant . ,(delay python2-h5py))))))
 
 (define-public python2-h5py
-  (package-with-python2 python-h5py))
+  (let ((base (package-with-python2 (strip-python2-variant python-h5py))))
+    (package
+      (inherit base)
+      (version "2.10.0")
+      (source
+       (origin
+         (method url-fetch)
+         (uri (pypi-uri "h5py" version))
+         (sha256
+          (base32
+           "0baipzv8n93m0dq0riyi8rfhzrjrfrfh8zqhszzp1j2xjac2fhc4")))))))
 
 (define-public python-hnswlib
   (package