summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/firmware.scm1
-rw-r--r--gnu/packages/patches/ath9k-htc-firmware-objcopy.patch4
2 files changed, 3 insertions, 2 deletions
diff --git a/gnu/packages/firmware.scm b/gnu/packages/firmware.scm
index 1d89dfba00..7923f5c908 100644
--- a/gnu/packages/firmware.scm
+++ b/gnu/packages/firmware.scm
@@ -121,6 +121,7 @@
              ;; 'configure' is a simple script that runs 'cmake' with
              ;; the right flags.
              (substitute* "configure"
+               (("^TARGET.*$") "TARGET=xtensa-elf\n")
                (("^TOOLCHAIN=.*$")
                 (string-append "TOOLCHAIN="
                                (assoc-ref (or native-inputs inputs) "cross-gcc")
diff --git a/gnu/packages/patches/ath9k-htc-firmware-objcopy.patch b/gnu/packages/patches/ath9k-htc-firmware-objcopy.patch
index 2172f8353f..13c3ca1413 100644
--- a/gnu/packages/patches/ath9k-htc-firmware-objcopy.patch
+++ b/gnu/packages/patches/ath9k-htc-firmware-objcopy.patch
@@ -1,5 +1,5 @@
 The firmware is cross-compiled, but the build system ends up using
-'objcopy' instead of 'xtensa-elf-objcopy' by default.  Force it to
+'objcopy' instead of '$TARGET-objcopy' by default.  Force it to
 use the right one.
 
 --- source/target_firmware/configure	2014-10-28 20:57:26.834436561 +0100
@@ -8,7 +8,7 @@ use the right one.
  cat > "$TOOLCHAIN_FILE" <<EOF
  INCLUDE(CMakeForceCompiler)
  
-+SET(CMAKE_OBJCOPY xtensa-elf-objcopy)
++SET(CMAKE_OBJCOPY ${TARGET}-objcopy)
  SET(CMAKE_SYSTEM_PROCESSOR xtensa)
  SET(CMAKE_FIND_ROOT_PATH ${TOOLCHAIN}/$TARGET)
  SET(CMAKE_STRIP :)