summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/docbook.scm4
1 files changed, 4 insertions, 0 deletions
diff --git a/gnu/packages/docbook.scm b/gnu/packages/docbook.scm
index cf30b95ab2..02cea45e97 100644
--- a/gnu/packages/docbook.scm
+++ b/gnu/packages/docbook.scm
@@ -923,11 +923,15 @@ Detect the differences in markup between two SGML files.
     (build-system gnu-build-system)
     (arguments
      (list
+      #:make-flags ''("AM_MAKEINFOHTMLFLAGS=\"--no-split\"")
       #:modules '((guix build gnu-build-system)
                   (guix build utils)
                   (srfi srfi-26))
       #:phases
       #~(modify-phases %standard-phases
+          (add-before 'build 'clean
+            (lambda _
+              (invoke "make" "clean")))
           (add-after 'install 'move-doc
             (lambda _
               (let* ((old (string-append #$output "/share/doc"))