summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/gawk.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/gawk.scm b/gnu/packages/gawk.scm
index 996be7af4a..74d0720567 100644
--- a/gnu/packages/gawk.scm
+++ b/gnu/packages/gawk.scm
@@ -1,6 +1,6 @@
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2012, 2013, 2014 Ludovic Courtès <ludo@gnu.org>
-;;; Copyright © 2014 Mark H Weaver <mhw@netris.org>
+;;; Copyright © 2014, 2015 Mark H Weaver <mhw@netris.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -59,7 +59,7 @@
 
                     ;; XXX FIXME prerelease libtool fails on MIPS in the
                     ;; absence of /usr/bin/file.
-                    ,@(if (equal? "mips64el-linux" (or (%current-target-system)
+                    ,@(if (string-prefix? "mips64" (or (%current-target-system)
                                                        (%current-system)))
                           '((substitute* "extension/configure"
                               (("/usr/bin/file") (which "file"))))