summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/ocaml.scm13
1 files changed, 13 insertions, 0 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 55bf4bfbeb..f85a78d97b 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -2060,6 +2060,19 @@ about.")
     (synopsis "Dune dynamic types")
     (description "This library represents dynamic types in OCaml.")))
 
+(define-public dune-stdune
+  (package
+    (inherit dune-ordering)
+    (name "dune-stdune")
+    (build-system dune-build-system)
+    (arguments
+     `(#:package "stdune"
+       ;; Tests have a cyclic dependency on itself
+       #:tests? #f))
+    (propagated-inputs (list dune-dyn ocaml-pp))
+    (synopsis "Unstable standard library from Dune")
+    (description "This library implements the standard functions used by Dune.")))
+
 (define-public ocaml-csexp
   (package
     (name "ocaml-csexp")