summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/emacs-xyz.scm12
1 files changed, 9 insertions, 3 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 86e0ad1108..0480b1b33f 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -20115,14 +20115,20 @@ fish-completion.  It can be used in both Eshell and M-x shell.")
                #t))
            (add-after 'unpack 'telega-paths-patch
              (lambda* (#:key inputs #:allow-other-keys)
-               ;; Hard-code path to `ffplay`.
+               ;; Hard-code paths to `ffplay` and `ffmpeg`.
                (let ((ffplay-bin (string-append (assoc-ref inputs "ffmpeg")
-                                                "/bin/ffplay")))
+                                                "/bin/ffplay"))
+                     (ffmpeg-bin (string-append (assoc-ref inputs "ffmpeg")
+                                                "/bin/ffmpeg")))
                  (substitute* "telega-ffplay.el"
                    (("\\(executable-find \"ffplay\"\\)")
                     (string-append
                      "(and (file-executable-p \"" ffplay-bin "\")"
-                     "\"" ffplay-bin "\")"))))
+                     "\"" ffplay-bin "\")"))
+                   (("\\(executable-find \"ffmpeg\"\\)")
+                    (string-append
+                     "(and (file-executable-p \"" ffmpeg-bin "\")"
+                     "\"" ffmpeg-bin "\")"))))
                ;; Modify telega-util to reflect unique dir name in
                ;; `telega-install-data' phase.
                (substitute* "telega-util.el"