summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/ftp.scm9
1 files changed, 8 insertions, 1 deletions
diff --git a/gnu/packages/ftp.scm b/gnu/packages/ftp.scm
index 68424c1591..481863bf33 100644
--- a/gnu/packages/ftp.scm
+++ b/gnu/packages/ftp.scm
@@ -272,11 +272,18 @@ directory comparison and more.")
     (arguments
      `(#:make-flags
        (list (string-append "CC=" ,(cc-for-target))
-             "LDFLAGS=-lcap -lcrypt -lpam"
+             ;; vsf_findlibs.sh looks only for hard-coded {/usr,}/lib file names
+             ;; that will never exist on Guix.  Manage libraries ourselves.
+             "LDFLAGS=-lcap -lpam"
              "INSTALL=install -D")
        #:tests? #f                      ; no test suite
        #:phases
        (modify-phases %standard-phases
+         (add-after 'unpack 'build-SSL
+           (lambda _
+             (substitute* "builddefs.h"
+               (("#undef (VSF_BUILD_SSL)" _ symbol)
+                (string-append "#define " symbol)))))
          (add-after 'unpack 'append-make-flags
            (lambda _
              (substitute* "Makefile"