summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/emacs-xyz.scm15
1 files changed, 8 insertions, 7 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 4f86cdc55a..d1809e8221 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -6884,13 +6884,14 @@ allrecipes.com.")
     (inputs
      (list pdf2svg))
     (arguments
-     `(#:phases
-       (modify-phases %standard-phases
-         (add-after 'unpack 'patch-exec-paths
-           (lambda* (#:key inputs #:allow-other-keys)
-             (let ((pdf2svg (assoc-ref inputs "pdf2svg")))
-               (substitute* "org-inline-pdf.el"
-                 (("\"pdf2svg\"") (string-append "\"" pdf2svg "/bin/pdf2svg\"")))))))))
+     (list
+      #:phases
+      #~(modify-phases %standard-phases
+          (add-after 'unpack 'patch-exec-paths
+            (lambda* (#:key inputs #:allow-other-keys)
+              (let ((pdf2svg (search-input-file inputs "/bin/pdf2svg")))
+                (substitute* "org-inline-pdf.el"
+                  (("\"pdf2svg\"") (string-append "\"" pdf2svg "\"")))))))))
     (home-page "https://github.com/shg/org-inline-pdf.el")
     (synopsis "Inline PDF previewing for Org")
     (description "This package provides a minor mode that enables