summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/ruby.scm5
1 files changed, 3 insertions, 2 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 7459222dc9..d61d67a7f7 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -4490,8 +4490,9 @@ is to be run.")
        `(#:phases
          (modify-phases %standard-phases
            (replace 'check
-             (lambda _
-               (invoke "sh" "script/test"))))))
+             (lambda* (#:key tests? #:allow-other-keys)
+               (when tests?
+                 (invoke "sh" "script/test")))))))
       (native-inputs
        (list bundler ruby-turn))
       (synopsis "Pretty-print hashes and arrays in MiniTest")